mpc85xx: enable squashfs feature
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 19 Feb 2013 14:53:15 +0000 (14:53 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 19 Feb 2013 14:53:15 +0000 (14:53 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35675 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/mpc85xx/Makefile
target/linux/mpc85xx/image/Makefile

index df8204d..92064d0 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
-FEATURES:=spe_fpu ramdisk
+FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 LINUX_VERSION:=3.7.9
index 45cd7ab..b762515 100644 (file)
@@ -24,6 +24,11 @@ define Image/Build/ext2
        cp $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-ext2.img
 endef
 
+define Image/Build/squashfs
+       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+       cp $(KDIR)/root.squashfs $(BIN_DIR)/$(IMG_PREFIX)-root.squashfs
+endef
+
 define Image/Build
        $(call Image/Build/$(1),$(1))
 endef