[lantiq] make hcd driver work with v3.8
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 14 Mar 2013 18:42:57 +0000 (18:42 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 14 Mar 2013 18:42:57 +0000 (18:42 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36019 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/platform/lantiq/ltq-hcd/Makefile
package/platform/lantiq/ltq-hcd/src/ifxusb_driver.c

index 6f654b4..74218c8 100644 (file)
@@ -23,13 +23,14 @@ define KernelPackage/ltq-hcd-template
   VARIANT:=$(1)
   DEPENDS:=@TARGET_lantiq_$(2) +kmod-usb-core
   FILES:=$(PKG_BUILD_DIR)/ltq_hcd_$(1).ko
-  AUTOLOAD:=$(call AutoLoad,50,ltq_hcd_$(1))
+  AUTOLOAD:=$(call AutoLoad,50,ltq_hcd_$(1),1)
 endef
 
 KernelPackage/ltq-hcd-ase=$(call KernelPackage/ltq-hcd-template,ase,ase)
 KernelPackage/ltq-hcd-danube=$(call KernelPackage/ltq-hcd-template,danube,xway)
 KernelPackage/ltq-hcd-ar9=$(call KernelPackage/ltq-hcd-template,ar9,xway)
 KernelPackage/ltq-hcd-vr9=$(call KernelPackage/ltq-hcd-template,vr9,xway)
+KernelPackage/ltq-hcd-ar10=$(call KernelPackage/ltq-hcd-template,ar10,xway)
 
 define Build/Prepare
        $(INSTALL_DIR) $(PKG_BUILD_DIR)
@@ -49,3 +50,4 @@ $(eval $(call KernelPackage,ltq-hcd-ase))
 $(eval $(call KernelPackage,ltq-hcd-danube))
 $(eval $(call KernelPackage,ltq-hcd-ar9))
 $(eval $(call KernelPackage,ltq-hcd-vr9))
+$(eval $(call KernelPackage,ltq-hcd-ar10))
index c30cf44..04346b9 100644 (file)
@@ -315,6 +315,8 @@ static int ifxusb_driver_probe(struct platform_device *_pdev)
         np = of_find_compatible_node(NULL, NULL, "lantiq,ifxhcd-arx100");
 #elif defined __IS_VR9__
         np = of_find_compatible_node(NULL, NULL, "lantiq,ifxhcd-xrx200");
+#elif defined __IS_AR10__
+        np = of_find_compatible_node(NULL, NULL, "lantiq,ifxhcd-arx300");
 #endif
        if (!np) {
                dev_err(&_pdev->dev, "failed to find hcd device node\n");