[kernel]: make thermal framework registered sensors also register as hwmons
authorImre Kaloz <kaloz@openwrt.org>
Fri, 20 Jun 2014 20:44:18 +0000 (20:44 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Fri, 20 Jun 2014 20:44:18 +0000 (20:44 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41290 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/other.mk

index 8f68bd8..2f6f774 100644 (file)
@@ -855,6 +855,7 @@ define KernelPackage/thermal
        CONFIG_THERMAL_GOV_FAIR_SHARE=n \
        CONFIG_THERMAL_GOV_STEP_WISE=y \
        CONFIG_THERMAL_GOV_USER_SPACE=n \
+       CONFIG_THERMAL_HWMON=y \
        CONFIG_THERMAL_EMULATION=n
   FILES:=$(LINUX_DIR)/drivers/thermal/thermal_sys.ko
   AUTOLOAD:=$(call AutoProbe,thermal_sys)