package/uhttpd: use new service wrapper
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Nov 2011 22:59:06 +0000 (22:59 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Nov 2011 22:59:06 +0000 (22:59 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28841 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/uhttpd/Makefile
package/uhttpd/files/uhttpd.init

index 6285eab..d8bd33c 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=28
+PKG_RELEASE:=29
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_CONFIG_DEPENDS := \
index 1ec0096..c370f90 100755 (executable)
@@ -2,10 +2,13 @@
 # Copyright (C) 2010 Jo-Philipp Wich
 
 START=50
+
+SERVICE_DAEMONIZE=1
+SERVICE_WRITE_PID=1
+
 UHTTPD_BIN="/usr/sbin/uhttpd"
 PX5G_BIN="/usr/sbin/px5g"
 
-
 append_arg() {
        local cfg="$1"
        local var="$2"
@@ -103,21 +106,16 @@ start_instance()
                }
        }
 
-       start-stop-daemon -S -x $UHTTPD_BIN \
-               -p /var/run/uhttpd_${cfg}.pid \
-               -m -b -- -f $UHTTPD_ARGS
+       SERVICE_PID_FILE=/var/run/uhttpd_${cfg}.pid
+       service_start $UHTTPD_BIN -f $UHTTPD_ARGS
 }
 
 stop_instance()
 {
        local cfg="$1"
 
-       [ -f /var/run/uhttpd_${cfg}.pid ] && {
-               start-stop-daemon -K -q -n ${UHTTPD_BIN##*/} \
-                       -p /var/run/uhttpd_${cfg}.pid -s TERM
-
-               rm -f /var/run/uhttpd_${cfg}.pid
-       }
+       SERVICE_PID_FILE=/var/run/uhttpd_${cfg}.pid
+       service_stop $UHTTPD_BIN
 }
 
 start() {