don't overwrite .config if it's a symlink (fixes scripts/env problems)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 18 Oct 2008 19:37:34 +0000 (19:37 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 18 Oct 2008 19:37:34 +0000 (19:37 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13005 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/toplevel.mk

index 9d0eb25..ab4448a 100644 (file)
@@ -48,7 +48,7 @@ prepare-tmpinfo: FORCE
        touch $(TOPDIR)/tmp/.build
 
 .config: ./scripts/config/conf prepare-tmpinfo $(if $(CONFIG_HAVE_DOT_CONFIG),,FORCE)
-       @+if [ \! -f .config ] || ! grep CONFIG_HAVE_DOT_CONFIG .config >/dev/null; then \
+       @+if [ \! -e .config ] || ! grep CONFIG_HAVE_DOT_CONFIG .config >/dev/null; then \
                [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
                $(_SINGLE)$(NO_TRACE_MAKE) menuconfig $(PREP_MK); \
        fi