Add libelf dependency, add disk and exec features to snmpd, add install-dev stuff
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 30 May 2005 05:56:37 +0000 (05:56 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 30 May 2005 05:56:37 +0000 (05:56 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1107 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/net-snmp/Config.in
openwrt/package/net-snmp/Makefile

index 8ebbc52..7e1b3b5 100644 (file)
@@ -6,12 +6,12 @@ config BR2_PACKAGE_NET_SNMP
        depends BR2_PACKAGE_LIBNETSNMP
 
 config BR2_PACKAGE_LIBNETSNMP
-       prompt "libnetsnmp - SNMP libraries"
+       prompt "libnetsnmp - SNMP shared libraries"
        tristate
        default m if CONFIG_DEVEL
        select BR2_PACKAGE_NET_SNMP
+       select BR2_PACKAGE_LIBELF
        help
-         
          Simple Network Management Protocol (SNMP) is a widely used 
          protocol for monitoring the health and welfare of network 
          equipment (eg. routers), computer equipment and even devices 
@@ -24,15 +24,37 @@ config BR2_PACKAGE_LIBNETSNMP
          
 
 config BR2_PACKAGE_SNMPD
-       depends BR2_PACKAGE_LIBNETSNMP
        prompt "snmpd - SNMP agent"
        tristate
+       select BR2_PACKAGE_LIBNETSNMP
        default m if CONFIG_DEVEL
+       help
+         Simple Network Management Protocol (SNMP) is a widely used 
+         protocol for monitoring the health and welfare of network 
+         equipment (eg. routers), computer equipment and even devices 
+         like UPSs. Net-SNMP is a suite of applications used to implement 
+         SNMP v1, SNMP v2c and SNMP v3 using both IPv4 and IPv6.
+         
+         http://www.net-snmp.org/
+         
+         This package contains the SNMP agent.
+         
 
 config BR2_PACKAGE_SNMP_UTILS
-       depends BR2_PACKAGE_LIBNETSNMP
        prompt "snmp-utils - SNMP client utilities"
        tristate
+       select BR2_PACKAGE_LIBNETSNMP
        default m if CONFIG_DEVEL
+       help
+         Simple Network Management Protocol (SNMP) is a widely used 
+         protocol for monitoring the health and welfare of network 
+         equipment (eg. routers), computer equipment and even devices 
+         like UPSs. Net-SNMP is a suite of applications used to implement 
+         SNMP v1, SNMP v2c and SNMP v3 using both IPv4 and IPv6.
+         
+         http://www.net-snmp.org/
+         
+         This package contains the SNMP client utilities.
+         
 
 endmenu
index 7211906..ba88748 100644 (file)
@@ -41,8 +41,11 @@ SNMP_MIB_MODULES_INCLUDED = \
        snmpv3/usmUser \
        snmpv3mibs \
        tunnel \
+       ucd-snmp/disk \
+       ucd-snmp/extensible \
        ucd-snmp/loadave \
        ucd-snmp/memory \
+       ucd-snmp/pass \
        ucd-snmp/proc \
        ucd-snmp/vmstat \
        util_funcs \
@@ -154,6 +157,26 @@ $(IPKG_SNMPD):
 
 $(IPKG_SNMP_UTILS):
        install -d -m0755 $(IDIR_SNMP_UTILS)/usr/bin
-       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/snmp{get,set,status,test,walk} $(IDIR_SNMP_UTILS)/usr/bin/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/snmp{get,set,status,test,trap,walk} $(IDIR_SNMP_UTILS)/usr/bin/
        $(RSTRIP) $(IDIR_SNMP_UTILS)
        $(IPKG_BUILD) $(IDIR_SNMP_UTILS) $(PACKAGE_DIR)
+
+$(STAGING_DIR)/usr/lib/libnetsnmp.so: $(PKG_BUILD_DIR)/.built
+       mkdir -p $(STAGING_DIR)/usr/bin
+       cp -fp $(PKG_INSTALL_DIR)/usr/bin/net-snmp-config $(STAGING_DIR)/usr/bin/
+       mkdir -p $(STAGING_DIR)/usr/include
+       cp -fpR $(PKG_INSTALL_DIR)/usr/include/net-snmp $(STAGING_DIR)/usr/include/
+       mkdir -p $(STAGING_DIR)/usr/lib
+       cp -fp $(PKG_INSTALL_DIR)/usr/lib/libnetsnmp{,agent,helpers,mibs}.{a,so*} $(STAGING_DIR)/usr/lib/
+       touch $@
+
+install-dev: $(STAGING_DIR)/usr/lib/libnetsnmp.so
+
+uninstall-dev:
+       rm -rf \
+               $(STAGING_DIR)/usr/bin/net-snmp-config \
+               $(STAGING_DIR)/usr/include/net-snmp \
+               $(STAGING_DIR)/usr/lib/libnetsnmp{,agent,helpers,mibs}.{a,so*} \
+
+compile: install-dev
+clean: uninstall-dev