build: use ONESHELL to speed up scanning and the toplevel makefile
authorFelix Fietkau <nbd@openwrt.org>
Wed, 22 Oct 2014 08:57:40 +0000 (08:57 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 22 Oct 2014 08:57:40 +0000 (08:57 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43021 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile
include/scan.mk
include/target.mk

index 91b6946..f75fc7f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -15,6 +15,7 @@ empty:=
 space:= $(empty) $(empty)
 $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces))
 
+.ONESHELL:
 world:
 
 include $(TOPDIR)/include/host.mk
index 0998333..2f2753f 100644 (file)
@@ -78,3 +78,4 @@ $(TMP_DIR)/.$(SCAN_TARGET): $(TARGET_STAMP) $(SCAN_STAMP)
 FORCE:
 .PHONY: FORCE
 .NOTPARALLEL:
+.ONESHELL:
index 3401f84..657109e 100644 (file)
@@ -19,6 +19,7 @@ DEFAULT_PACKAGES.bootloader:=
 
 ifneq ($(DUMP),)
   all: dumpinfo
+  .ONESHELL:
 endif
 
 target_conf=$(subst .,_,$(subst -,_,$(subst /,_,$(1))))