package/uboot-lantiq: move configuration in submenu
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 16 Apr 2010 11:08:19 +0000 (11:08 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 16 Apr 2010 11:08:19 +0000 (11:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20919 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/uboot-lantiq/Config.in
package/uboot-lantiq/Makefile

index e2c156d..578b088 100644 (file)
@@ -1,7 +1,9 @@
+menu "Configuration"
+       depends on PACKAGE_uboot-lantiq
+
 config UBOOT_TARGET
        string "target"
        default "easy50712_DDR166M"
-       depends on PACKAGE_uboot-lantiq
        help
          The configuration reflects the settings for a dedicated board hardware.
          Select for Danube evaluation board easy50712_DDR166M .
@@ -9,7 +11,6 @@ config UBOOT_TARGET
 
 config UBOOT_RAMBOOT
        bool "Enable RAM boot image"
-       depends on PACKAGE_uboot-lantiq
        help
          Using the UART boot mode of the ROM code this image could be loaded to the RAM.
          While executing the image in the RAM the functionality of the uboot image can be 
@@ -30,6 +31,7 @@ config UBOOT_RAMBOOT_DDR_CONFIG
 
 config UBOOT_A800
        bool "add ARV452 Switch bringup hack"
-       depends on PACKAGE_uboot-lantiq
        help
          Say Y, if you have a arv452 board (wav-281, A800, ..)
+
+endmenu
index 1864908..8b69fe9 100644 (file)
@@ -31,6 +31,7 @@ define Package/uboot-lantiq
   DEPENDS:=@TARGET_ifxmips
   TITLE:=U-Boot for Lantiq reference boards
   URL:=http://www.denx.de/wiki/U-Boot
+  MENU:=1
 endef
 
 define Build/Prepare