generic/4.4: bump to -rc5
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 15 Dec 2015 11:20:38 +0000 (11:20 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 15 Dec 2015 11:20:38 +0000 (11:20 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47894 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-version.mk
target/linux/generic/patches-4.4/834-ledtrig-libata.patch
target/linux/generic/patches-4.4/863-gpiommc.patch
target/linux/generic/patches-4.4/902-debloat_proc.patch
target/linux/generic/patches-4.4/997-device_tree_cmdline.patch
target/linux/mvebu/patches-4.4/000-sata_use_ifdef_around_suspend_resume.patch [deleted file]

index 201c2a9..b5b5fc4 100644 (file)
@@ -5,12 +5,12 @@ LINUX_RELEASE?=1
 LINUX_VERSION-3.18 = .23
 LINUX_VERSION-4.1 = .13
 LINUX_VERSION-4.3 =
-LINUX_VERSION-4.4 = -rc4
+LINUX_VERSION-4.4 = -rc5
 
 LINUX_KERNEL_MD5SUM-3.18.23 = dc6d265ab38716be3676ac294b481ad8
 LINUX_KERNEL_MD5SUM-4.1.13 = af9dd5d8f71185a64a8eccface15fc00
 LINUX_KERNEL_MD5SUM-4.3 = 58b35794eee3b6d52ce7be39357801e7
-LINUX_KERNEL_MD5SUM-4.4-rc4 = 893caa049cd5c680bf6770603d6cb416
+LINUX_KERNEL_MD5SUM-4.4-rc5 = 7516a83ce861c7b2324975c82c413157
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index 6c6e78e..c60fc1a 100644 (file)
@@ -138,7 +138,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
  /*
   * Define if arch has non-standard setup.  This is a _PCI_ standard
-@@ -876,6 +879,12 @@ struct ata_port {
+@@ -877,6 +880,12 @@ struct ata_port {
  #ifdef CONFIG_ATA_ACPI
        struct ata_acpi_gtm     __acpi_init_gtm; /* use ata_acpi_init_gtm() */
  #endif
index de112d4..55982b6 100644 (file)
 +be done automatically.
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -4879,6 +4879,11 @@ T:      git git://linuxtv.org/anttip/media_tr
+@@ -4880,6 +4880,11 @@ T:      git git://linuxtv.org/anttip/media_tr
  S:    Maintained
  F:    drivers/media/usb/hackrf/
  
index 2d7cc5d..57ceeae 100644 (file)
  }
 --- a/mm/vmstat.c
 +++ b/mm/vmstat.c
-@@ -1551,10 +1551,12 @@ static int __init setup_vmstat(void)
-       cpu_notifier_register_done();
+@@ -1553,10 +1553,12 @@ static int __init setup_vmstat(void)
+       vmstat_wq = alloc_workqueue("vmstat", WQ_FREEZABLE|WQ_MEM_RECLAIM, 0);
  #endif
  #ifdef CONFIG_PROC_FS
 -      proc_create("buddyinfo", S_IRUGO, NULL, &fragmentation_file_operations);
index 2ea4149..566648f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/of/fdt.c
 +++ b/drivers/of/fdt.c
-@@ -951,6 +951,9 @@ int __init early_init_dt_scan_chosen(uns
+@@ -956,6 +956,9 @@ int __init early_init_dt_scan_chosen(uns
        p = of_get_flat_dt_prop(node, "bootargs", &l);
        if (p != NULL && l > 0)
                strlcpy(data, p, min((int)l, COMMAND_LINE_SIZE));
diff --git a/target/linux/mvebu/patches-4.4/000-sata_use_ifdef_around_suspend_resume.patch b/target/linux/mvebu/patches-4.4/000-sata_use_ifdef_around_suspend_resume.patch
deleted file mode 100644 (file)
index ba0bd96..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-The newly added suspend/resume implementation for ahci_mvebu causes
-a link error when CONFIG_PM_SUSPEND is disabled:
-
-ERROR: "ahci_platform_suspend_host" [drivers/ata/ahci_mvebu.ko] undefined!
-ERROR: "ahci_platform_resume_host" [drivers/ata/ahci_mvebu.ko] undefined!
-
-This adds the same #ifdef here that exists in the ahci_platform driver
-which defines the above functions.
-
-Signed-off-by: Arnd Bergmann <arnd@arndb.de>
-Fixes: d6ecf1581488 ("ata: ahci_mvebu: add suspend/resume support")
-Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
---- a/drivers/ata/ahci_mvebu.c
-+++ b/drivers/ata/ahci_mvebu.c
-@@ -62,6 +62,7 @@ static void ahci_mvebu_regret_option(str
-       writel(0x80, hpriv->mmio + AHCI_VENDOR_SPECIFIC_0_DATA);
- }
-+#ifdef CONFIG_PM_SLEEP
- static int ahci_mvebu_suspend(struct platform_device *pdev, pm_message_t state)
- {
-       return ahci_platform_suspend_host(&pdev->dev);
-@@ -81,6 +82,10 @@ static int ahci_mvebu_resume(struct plat
-       return ahci_platform_resume_host(&pdev->dev);
- }
-+#else
-+#define ahci_mvebu_suspend NULL
-+#define ahci_mvebu_resume NULL
-+#endif
- static const struct ata_port_info ahci_mvebu_port_info = {
-       .flags     = AHCI_FLAG_COMMON,