support for the asus wl-500g deluxe and the buffalo v2 units. dnsmasq update, control...
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Mar 2005 17:52:30 +0000 (17:52 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Mar 2005 17:52:30 +0000 (17:52 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@390 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/dnsmasq/Makefile
openwrt/package/dnsmasq/dnsmasq.control
openwrt/package/dropbear/dropbear.control
openwrt/package/iptables/control/ip6tables.control
openwrt/package/iptables/control/iptables-extra.control
openwrt/package/iptables/control/iptables.control
openwrt/package/linux/kernel-source/arch/mips/brcm-boards/bcm947xx/sbpci.c
openwrt/package/linux/kernel-source/drivers/net/diag/diag_led.c
openwrt/target/default/target_skeleton/etc/init.d/S10boot
openwrt/target/default/target_skeleton/etc/nvram.overrides

index 899bad7..761b798 100644 (file)
@@ -6,7 +6,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.15
+PKG_VERSION:=2.20
 PKG_RELEASE:=1
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index ef6bd0d..3aba02b 100644 (file)
@@ -1,7 +1,7 @@
 Package: dnsmasq
 Priority: essential
 Section: net
-Version: 2.15-1
+Version: 2.20-1
 Architecture: mipsel
 Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
 Source: buildroot internal
index e30f02a..1a2f5ed 100644 (file)
@@ -2,7 +2,7 @@ Package: dropbear
 Priority: optional
 Depends: zlib
 Section: net
-Version: 0.44-1
+Version: 0.45-1
 Architecture: mipsel
 Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
 Source: buildroot internal
index 4f7da56..6739656 100644 (file)
@@ -2,7 +2,7 @@ Package: ip6tables
 Priority: optional
 Depends: kmod-ipv6
 Section: net
-Version: 1.2.11-1
+Version: 1.3.0-1
 Architecture: mipsel
 Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
 Source: buildroot internal
index 2ce6044..eb3dd7b 100644 (file)
@@ -1,7 +1,7 @@
 Package: iptables-extra
 Priority: optional
 Section: net
-Version: 1.2.11-1
+Version: 1.3.0-1
 Architecture: mipsel
 Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
 Source: buildroot internal
index 09a99b5..6b7ab38 100644 (file)
@@ -1,7 +1,7 @@
 Package: iptables
 Priority: optional
 Section: net
-Version: 1.2.11-1
+Version: 1.3.0-1
 Architecture: mipsel
 Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
 Source: buildroot internal
index b346913..ead31e9 100644 (file)
@@ -275,7 +275,7 @@ sbpci_init(void *sbh)
        sb_core_reset(sbh, 0);
 
        /* In some board, */ 
-       if(nvram_match("boardtype", "bcm94710dev"))
+       if(nvram_match("boardtype", "bcm94710dev") || nvram_match("boardtype", "bcm94710ap")|| nvram_match("boardtype", "bcm94710r4")|| nvram_match("boardtype", "bcm94710r4")|| nvram_match("boardtype", "bcm95365r"))
                CT4712_WR = 0;
        else
                CT4712_WR = 1;
index 41cb17b..6f1ba97 100644 (file)
@@ -5,6 +5,7 @@
 // initial release 2004/03/28
 //
 // 2004/08/26 asus & buffalo support added
+// 2005/03/14 asus wl-500g deluxe and buffalo v2 support added
 
 #include <linux/module.h>
 #include <linux/init.h>
@@ -187,11 +188,26 @@ static int __init diag_init()
                reset_polarity=0;
                buf=nvram_get("boardnum")?:"";
                if (!strcmp(buf,"44")) {
+                       //motorola
                        set_diag=ignore;
                        set_dmz=ignore;
                        reset_gpio=(1<<5);
                        reset_polarity=0;
                }
+               if (!strcmp(buf,"00")) {
+                       //buffalo
+                       set_diag=ignore;
+                       set_dmz=ignore;
+                       reset_gpio=(1<<7);
+                       reset_polarity=1;
+               }
+               if (!strcmp(buf,"45")) {
+                       //wl-500g deluxe
+                       set_diag=ignore;
+                       set_dmz=ignore;
+                       reset_gpio=(1<<6);
+                       reset_polarity=1;
+               }
        }
        printk(KERN_INFO "using v%d hardware\n",board_type);
 
index 928fc58..1a36583 100755 (executable)
@@ -15,6 +15,16 @@ touch /var/log/lastlog
   awk '{OFS=FS=":";for(x=7,y=2;--x;){$x=sprintf("%02x",(y+="0x"$x)%256);y/=256}print}')
 }
 
+# set up the vlan*ports variables for the asus wl-500g deluxe, if they aren't exist
+[ "$(nvram get boardtype)" = "bcm95365r" ] && \
+[ "$(nvram get boardnum)" = "45" ] && {
+  [ -z "$(nvram get vlan0ports)" ] && \
+  [ -z "$(nvram get vlan1ports)" ] && {
+    nvram set vlan0ports="1 2 3 4 5*"
+    nvram set vlan1ports="0 5"
+  }
+}
+
 sed 's/^[^#]/insmod &/' /etc/modules 2>&-|ash
 
 ifconfig lo 127.0.0.1 up
index 206c90b..82c1590 100644 (file)
@@ -45,11 +45,29 @@ NVRAM_lan_proto="static"
   FAILSAFE_ifnames="eth0 eth1"
 }
 
+# hacks for buffalo wla2-g54l
+[ "$(nvram get boardnum)" = "00" ] && \
+[ "$(nvram get product_name)" = "Product_name" ] && {
+  debug "### wla2-g54l hacks ###"
+  NVRAM_lan_ifnames="vlan0"
+  NVRAM_wan_ifname="none"
+}
+
 # hack for asus wl-500g hardware
 [ $asus ] && {
     FAILSAFE_lan_ifnames="eth0 eth2"
 }
 
+# hacks for asus wl-500g deluxe
+[ "$(nvram get boardtype)" = "bcm95365r" ] && \
+[ "$(nvram get boardnum)" = "45" ] && {
+  debug "### wl-500g deluxe hacks ###"
+  NVRAM_vlan0hwname="et0"
+  NVRAM_vlan1hwname="et0"
+  NVRAM_lan_ifnames="vlan0 eth1"
+  NVRAM_wan_ifname="vlan1"
+}
+
 # defaults if lan_ifname is missing
 [ -z "$(nvram get lan_ifname)" ] && {
   NVRAM_lan_ifname="br0"