oxnas: change file extension of u-boot+initramfs image
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Jun 2015 17:42:00 +0000 (17:42 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Jun 2015 17:42:00 +0000 (17:42 +0000)
The *u-boot-initramfs* images are not ITB/FIT images but are rather
supposed to be loaded to RAM and jumped-into.
To avoid confusion, change the file extension from itb to bin.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45963 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/oxnas/image/Makefile

index 2660a9b..de6c4db 100644 (file)
@@ -38,7 +38,7 @@ define Image/BuildKernel/Template
        $(CP) $(KDIR)/fit-$(1)-initramfs.itb $(BIN_DIR)/$(IMG_PREFIX)-$(1)-fit-uImage-initramfs.itb
        if [ -e "$(KDIR)/u-boot.bin" ]; then \
        ( dd if=$(KDIR)/u-boot.bin bs=128k conv=sync ; dd if=$(KDIR)/fit-$(1)-initramfs.itb bs=128k conv=sync ) \
-               > $(BIN_DIR)/$(IMG_PREFIX)-$(1)-u-boot-initramfs.itb; \
+               > $(BIN_DIR)/$(IMG_PREFIX)-$(1)-u-boot-initramfs.bin; \
        fi
  endif