fix broken openser menuconfig and package template call
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 19 Mar 2006 04:53:42 +0000 (04:53 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 19 Mar 2006 04:53:42 +0000 (04:53 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3409 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/openser/Config.in
package/openser/Makefile

index b7580a6..cbbb36b 100644 (file)
@@ -11,229 +11,228 @@ config BR2_PACKAGE_OPENSER
 config BR2_PACKAGE_OPENSER_MOD_AUTH
        prompt "openser-mod-auth.................. Authentication support"
        tristate
-       default m
-       select BR2_PACKAGE_OPENSER
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
        help
          Enable authentication support
 
 config BR2_PACKAGE_OPENSER_MOD_AUTH_DB
        prompt "openser-mod-auth-db............... Authentication with database support"
        tristate
-       default m
-       select BR2_PACKAGE_OPENSER
-       select BR2_PACKAGE_OPENSER_MOD_AUTH
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER_MOD_AUTH
        help
          Enable authentication with database support
 
 config BR2_PACKAGE_OPENSER_MOD_AUTH_RADIUS
        prompt "openser-mod-auth-radius........... Authentication with RADIUS support"
        tristate
-       default m
-       select BR2_PACKAGE_OPENSER
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER_MOD_AUTH
        select BR2_PACKAGE_LIBRADIUSCLIENT_NG
        help
          Authentication against RADIUS
 
 config BR2_PACKAGE_OPENSER_MOD_AVP_RADIUS
-        prompt "openser-mod-avp-radius............ AVP with RADIUS support"
+       prompt "openser-mod-avp-radius............ AVP with RADIUS support"
        tristate
-        default m
-        select BR2_PACKAGE_OPENSER
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
        select BR2_PACKAGE_LIBRADIUSCLIENT_NG
-        help
-          Enable AVP with RADIUS support
+       help
+         Enable AVP with RADIUS support
 
 config BR2_PACKAGE_OPENSER_MOD_AVPOPS
        prompt "openser-mod-avpops................ AVP options support"
        tristate
-       default m
-       select BR2_PACKAGE_OPENSER
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
        help
          Enable AVP options support
 
 config BR2_PACKAGE_OPENSER_MOD_DISPATCHER
-        prompt "openser-mod-dispatcher............ dispatcher support"
+       prompt "openser-mod-dispatcher............ dispatcher support"
        tristate
-        default m
-        select BR2_PACKAGE_OPENSER
-        help
-          Enable dispatcher options support
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
+       help
+         Enable dispatcher options support
 
 config BR2_PACKAGE_OPENSER_MOD_DIVERSION
-        prompt "openser-mod-diversion............. diversion support"
+       prompt "openser-mod-diversion............. diversion support"
        tristate
-        default m
-        select BR2_PACKAGE_OPENSER
-        help
-          Enable diversion options support
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
+       help
+         Enable diversion options support
 
 config BR2_PACKAGE_OPENSER_MOD_FLATSTORE
-        prompt "openser-mod-flatstore............. flatstore support"
+       prompt "openser-mod-flatstore............. flatstore support"
        tristate
-        default m
-        select BR2_PACKAGE_OPENSER
-        help
-          Enable flatstore support
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
+       help
+         Enable flatstore support
 
 config BR2_PACKAGE_OPENSER_MOD_GFLAGS
-        prompt "openser-mod-gflags................ gflags support"
+       prompt "openser-mod-gflags................ gflags support"
        tristate
-        default m
-        select BR2_PACKAGE_OPENSER
-        help
-          Enable GFlags support
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
+       help
+         Enable GFlags support
 
 config BR2_PACKAGE_OPENSER_MOD_GROUP
-        prompt "openser-mod-group................. group support"
+       prompt "openser-mod-group................. group support"
        tristate
-        default m
-        select BR2_PACKAGE_OPENSER
-        help
-          Enable group support
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
+       help
+         Enable group support
 
 config BR2_PACKAGE_OPENSER_MOD_GROUP_RADIUS
-        prompt "openser-mod-group-radius.......... group with RADIUS support"
+       prompt "openser-mod-group-radius.......... group with RADIUS support"
        tristate
-        default m
-        select BR2_PACKAGE_OPENSER
-        help
-          Enable group with RADIUS support
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
+       help
+         Enable group with RADIUS support
 
 config BR2_PACKAGE_OPENSER_MOD_LCR
-        prompt "openser-mod-lcr................... Least Cost Routing support"
+       prompt "openser-mod-lcr................... Least Cost Routing support"
        tristate
-        default m
-        select BR2_PACKAGE_OPENSER
-        select BR2_PACKAGE_OPENSER_MOD_MYSQL
-        help
-          Enable Least Cost Routing support
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
+       select BR2_PACKAGE_OPENSER_MOD_MYSQL
+       help
+         Enable Least Cost Routing support
 
 config BR2_PACKAGE_OPENSER_MOD_MEDIAPROXY
        prompt "openser-mod-mediaproxy............ Mediaproxy support"
        tristate
-       default m
-       select BR2_PACKAGE_OPENSER
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
        help
          Enable mediaproxy support
 
 config BR2_PACKAGE_OPENSER_MOD_MSILO
-        prompt "openser-mod-msilo................. MSilo support"
+       prompt "openser-mod-msilo................. MSilo support"
        tristate
-        default m
-        select BR2_PACKAGE_OPENSER
-        help
-          Enable msilo support
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
+       help
+         Enable msilo support
 
 config BR2_PACKAGE_OPENSER_MOD_MYSQL
-        prompt "openser-mod-mysql................. MySQL support"
+       prompt "openser-mod-mysql................. MySQL support"
        tristate
-        default m
-        select BR2_PACKAGE_LIBMYSQLCLIENT
-        select BR2_PACKAGE_OPENSER
-        help
-          Enable MySQL support
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_LIBMYSQLCLIENT
+       depends BR2_PACKAGE_OPENSER
+       help
+         Enable MySQL support
 
 config BR2_PACKAGE_OPENSER_MOD_NATHELPER
        prompt "openser-mod-nathelper............. NAT helper support"
        tristate
-       default m
-       select BR2_PACKAGE_OPENSER
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
        help
          NAT helper support
 
 config BR2_PACKAGE_OPENSER_MOD_OPTIONS
-        prompt "openser-mod-options............... options support"
+       prompt "openser-mod-options............... options support"
        tristate
-        default m
-        select BR2_PACKAGE_OPENSER
-        help
-          Enable options support
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
+       help
+         Enable options support
 
 config BR2_PACKAGE_OPENSER_MOD_PDT
-        prompt "openser-mod-pdt................... PDT support"
+       prompt "openser-mod-pdt................... PDT support"
        tristate
-        default m
-        select BR2_PACKAGE_OPENSER
-        help
-          Enable pdt support
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
+       help
+         Enable pdt support
 
 config BR2_PACKAGE_OPENSER_MOD_PERMISSIONS
-        prompt "openser-mod-permissions........... Permissions support"
+       prompt "openser-mod-permissions........... Permissions support"
        tristate
-        default m
-        select BR2_PACKAGE_OPENSER
-        help
-          Enable permissions support
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
+       help
+         Enable permissions support
 
 config BR2_PACKAGE_OPENSER_MOD_PIKE
-        prompt "openser-mod-pike.................. PIKE support"
+       prompt "openser-mod-pike.................. PIKE support"
        tristate
-        default m
-        select BR2_PACKAGE_OPENSER
-        help
-          Enable pike support
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
+       help
+         Enable pike support
 
 config BR2_PACKAGE_OPENSER_MOD_SMS
        prompt "openser-mod-sms................... SMS support"
        tristate
-       default m
-       select BR2_PACKAGE_OPENSER
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
        help
          SMS support
 
 config BR2_PACKAGE_OPENSER_MOD_SPEEDDIAL
        prompt "openser-mod-speeddial............. Speed Dial support"
        tristate
-       default m
-       select BR2_PACKAGE_OPENSER
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
        help
          Speed Dial support
 
 config BR2_PACKAGE_OPENSER_MOD_UAC
-        prompt "openser-mod-uac................... UAC support"
+       prompt "openser-mod-uac................... UAC support"
        tristate
-        default m
-        select BR2_PACKAGE_OPENSER
-        help
-          Enable UAC support
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
+       help
+         Enable UAC support
 
 config BR2_PACKAGE_OPENSER_MOD_UAC_REDIRECT
-        prompt "openser-mod-uac................... UAC redirect support"
+       prompt "openser-mod-uac................... UAC redirect support"
        tristate
-        default m
-        select BR2_PACKAGE_OPENSER
-        help
-          Enable UAC redirect support
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
+       help
+         Enable UAC redirect support
 
 config BR2_PACKAGE_OPENSER_MOD_URI
-        prompt "openser-mod-uri................... URI support"
+       prompt "openser-mod-uri................... URI support"
        tristate
-        default m
-        select BR2_PACKAGE_OPENSER
-        help
-          Enable URI support
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
+       help
+         Enable URI support
 
 config BR2_PACKAGE_OPENSER_MOD_URI_DB
-        prompt "openser-mod-uri-db................ URI database support"
+       prompt "openser-mod-uri-db................ URI database support"
        tristate
-        default m
-        select BR2_PACKAGE_OPENSER
-        help
-          Enable URI database support
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
+       help
+         Enable URI database support
 
 config BR2_PACKAGE_OPENSER_MOD_URI_RADIUS
-        prompt "openser-mod-uri-radius............ URI with RADIUS support"
+       prompt "openser-mod-uri-radius............ URI with RADIUS support"
        tristate
-        default m
-        select BR2_PACKAGE_OPENSER
-        help
-          Enable URI with RADIUS support
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
+       help
+         Enable URI with RADIUS support
 
 config BR2_PACKAGE_OPENSER_MOD_XLOG
        prompt "openser-mod-xlog.................. Logging support"
        tristate
-       default m
-       select BR2_PACKAGE_OPENSER
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OPENSER
        help
          Logging support
 
index 7ea52d1..72a8fe3 100644 (file)
@@ -57,7 +57,6 @@ $(eval $(call PKG_template,OPENSER_MOD_UAC_REDIRECT,openser-mod-uac-redirect,$(P
 $(eval $(call PKG_template,OPENSER_MOD_URI,openser-mod-uri,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_URI_DB,openser-mod-uri-db,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_URI_RADIUS,openser-mod-uri-radius,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,OPENSER_MOD_AUTH_RADIUS,openser-mod-auth-radius,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_XLOG,openser-mod-xlog,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(eval $(call PKG_mod_template,OPENSER_MOD_ACCOUNTING,acc))