kernel: fix pkt_type filter mask for packet sockets
authorFelix Fietkau <nbd@openwrt.org>
Fri, 13 Jun 2014 09:34:03 +0000 (09:34 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 13 Jun 2014 09:34:03 +0000 (09:34 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41178 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/mac80211/Makefile
target/linux/generic/patches-3.10/630-packet_socket_type.patch
target/linux/generic/patches-3.12/630-packet_socket_type.patch
target/linux/generic/patches-3.13/630-packet_socket_type.patch
target/linux/generic/patches-3.14/630-packet_socket_type.patch
target/linux/generic/patches-3.3/630-packet_socket_type.patch
target/linux/generic/patches-3.6/630-packet_socket_type.patch
target/linux/generic/patches-3.8/630-packet_socket_type.patch
target/linux/generic/patches-3.9/630-packet_socket_type.patch

index e260993..9ea01a8 100644 (file)
@@ -1447,7 +1447,7 @@ endif
 config-$(call config_package,lib80211) += LIB80211 LIB80211_CRYPT_WEP LIB80211_CRYPT_CCMP LIB80211_CRYPT_TKIP
 
 config-$(call config_package,ath) += ATH_CARDS ATH_COMMON
-config-$(CONFIG_PACKAGE_ATH_DEBUG) += ATH_DEBUG ATH10K_DEBUG
+config-$(CONFIG_PACKAGE_ATH_DEBUG) += ATH_DEBUG ATH10K_DEBUG ATH9K_TX99
 config-$(CONFIG_PACKAGE_ATH_DFS) += ATH9K_DFS_CERTIFIED ATH10K_DFS_CERTIFIED
 
 config-$(call config_package,ath9k) += ATH9K
index 14878d3..3a3c3bb 100644 (file)
@@ -102,7 +102,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
 +                        return -EINVAL;
 +                if (copy_from_user(&val, optval, sizeof(val)))
 +                        return -EFAULT;
-+                po->pkt_type = val & ~PACKET_LOOPBACK;
++                po->pkt_type = val & ~BIT(PACKET_LOOPBACK);
 +                return 0;
 +        }
        default:
index 1e915f6..60e8401 100644 (file)
@@ -102,7 +102,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
 +                        return -EINVAL;
 +                if (copy_from_user(&val, optval, sizeof(val)))
 +                        return -EFAULT;
-+                po->pkt_type = val & ~PACKET_LOOPBACK;
++                po->pkt_type = val & ~BIT(PACKET_LOOPBACK);
 +                return 0;
 +        }
        default:
index 1e915f6..60e8401 100644 (file)
@@ -102,7 +102,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
 +                        return -EINVAL;
 +                if (copy_from_user(&val, optval, sizeof(val)))
 +                        return -EFAULT;
-+                po->pkt_type = val & ~PACKET_LOOPBACK;
++                po->pkt_type = val & ~BIT(PACKET_LOOPBACK);
 +                return 0;
 +        }
        default:
index d0247af..4f3f5e8 100644 (file)
@@ -102,7 +102,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
 +                        return -EINVAL;
 +                if (copy_from_user(&val, optval, sizeof(val)))
 +                        return -EFAULT;
-+                po->pkt_type = val & ~PACKET_LOOPBACK;
++                po->pkt_type = val & ~BIT(PACKET_LOOPBACK);
 +                return 0;
 +        }
        default:
index 231b745..bcb3991 100644 (file)
@@ -110,7 +110,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
 +                        return -EINVAL;
 +                if (copy_from_user(&val, optval, sizeof(val)))
 +                        return -EFAULT;
-+                po->pkt_type = val & ~PACKET_LOOPBACK;
++                po->pkt_type = val & ~BIT(PACKET_LOOPBACK);
 +                return 0;
 +        }
        default:
index a630d1d..b43c145 100644 (file)
@@ -110,7 +110,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
 +                        return -EINVAL;
 +                if (copy_from_user(&val, optval, sizeof(val)))
 +                        return -EFAULT;
-+                po->pkt_type = val & ~PACKET_LOOPBACK;
++                po->pkt_type = val & ~BIT(PACKET_LOOPBACK);
 +                return 0;
 +        }
        default:
index 0671a28..d1a9ee2 100644 (file)
@@ -102,7 +102,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
 +                        return -EINVAL;
 +                if (copy_from_user(&val, optval, sizeof(val)))
 +                        return -EFAULT;
-+                po->pkt_type = val & ~PACKET_LOOPBACK;
++                po->pkt_type = val & ~BIT(PACKET_LOOPBACK);
 +                return 0;
 +        }
        default:
index 9b700f5..ff57bb7 100644 (file)
@@ -102,7 +102,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
 +                        return -EINVAL;
 +                if (copy_from_user(&val, optval, sizeof(val)))
 +                        return -EFAULT;
-+                po->pkt_type = val & ~PACKET_LOOPBACK;
++                po->pkt_type = val & ~BIT(PACKET_LOOPBACK);
 +                return 0;
 +        }
        default: