[package] switch: the hardware must be up while configuring
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 13 Mar 2012 21:15:41 +0000 (21:15 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 13 Mar 2012 21:15:41 +0000 (21:15 +0000)
Since the removal of the interface coldplug hack the timing changed in such a way that eth0 is not up during switch setup,
leading to an inaccesible device. Bring up the switch interface before configuring it to mitigate the problem.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30937 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/switch/Makefile
package/switch/files/switch.sh

index 364416d..2b036b0 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=kmod-switch
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 include $(INCLUDE_DIR)/package.mk
 
index 6517ca9..2563d41 100644 (file)
@@ -11,6 +11,7 @@ setup_switch_hw() {
 
        local proc="/proc/switch/$dev"
        [ -d "$proc" ] && {
+               ifconfig "$dev" up
                echo "$reset"  > "$proc/reset"
                echo "$evlan"  > "$proc/enable_vlan"
                [ -f "$proc/enable" ] && echo "$enable" > "$proc/enable"