Fix lcd4linux package, remove PNG driver
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 19 May 2005 05:49:38 +0000 (05:49 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 19 May 2005 05:49:38 +0000 (05:49 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@948 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/lcd4linux/Config.in
openwrt/package/lcd4linux/Makefile

index e04e2f9..c08212c 100644 (file)
@@ -1,10 +1,10 @@
 config BR2_PACKAGE_LCD4LINUX
        tristate "lcd4linux - Program to access an external LCD"
        default m if CONFIG_DEVEL
-       select BR2_PACKAGE_NCURSES
+       select BR2_PACKAGE_LIBNCURSES
        help
          LCD4Linux
          
-       https://ssl.bulix.org/projects/lcd4linux/wiki/Howto
+         https://ssl.bulix.org/projects/lcd4linux/wiki/Howto
          
 
index 5586e65..04bde69 100644 (file)
@@ -24,7 +24,6 @@ $(PKG_BUILD_DIR)/.configured:
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
-               LIBS="-lpng12 -lz" \
                ./configure \
                  --target=$(GNU_TARGET_NAME) \
                  --host=$(GNU_TARGET_NAME) \
@@ -46,7 +45,7 @@ $(PKG_BUILD_DIR)/.configured:
                  $(DISABLE_LARGEFILE) \
                  $(DISABLE_NLS) \
                  --without-x \
-                 --with-drivers='all,!RouterBoard,!X11' \
+                 --with-drivers='all,!PNG,!RouterBoard,!X11' \
                  --with-plugins=wireless \
        )
        touch $@