misc cosmetic fixes:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 8 Jan 2007 11:19:08 +0000 (11:19 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 8 Jan 2007 11:19:08 +0000 (11:19 +0000)
 * reorder PKG_* variables, Build/(Un)InstallDev macros
 * remove unneeded configure options and PKG_INSTALL_DIR stuff
 * remove dupe descriptions

git-svn-id: svn://svn.openwrt.org/openwrt/packages@6035 3c298f89-4303-0410-b956-a3cf2f4a3e73

31 files changed:
libs/bzip2/Makefile
libs/flac/Makefile
libs/gd/Makefile
libs/libamsel/Makefile
libs/libnet-1.0.x/Makefile
libs/libnet-1.1.x/Makefile
libs/libnids/Makefile
libs/lzo/Makefile
libs/matrixssl/Makefile
libs/uclibc++/Makefile
net/aircrack-ng/Makefile
net/amwall/Makefile
net/atftp/Makefile
net/bwm/Makefile
net/cutter/Makefile
net/ethtool/Makefile
net/fprobe-ulog/Makefile
net/fprobe/Makefile
net/frickin/Makefile
net/gpsd/Makefile
net/iperf/Makefile
net/ipkungfu/Makefile
net/netperf/Makefile
net/oidentd/Makefile
net/privoxy/Makefile
net/reaim/Makefile
net/ttcp/Makefile
net/vncrepeater/Makefile
net/vsftpd/Makefile
sound/mt-daapd/Makefile
utils/mutt/Makefile

index fa753a4..af19e87 100644 (file)
@@ -25,7 +25,7 @@ define Package/libbzip2
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=bzip2 is a freely available, patent free, high-quality data compressor.
-  URL:=http://www.bzip.org
+  URL:=http://www.bzip.org/
 endef
 
 define Build/Compile
@@ -47,4 +47,4 @@ define Build/UninstallDev
                $(STAGING_DIR)/usr/lib/libbz2.a
 endef
 
-$(eval $(call BuildPackage,libbzip2))
+$(eval $(call Build/DefaultTargets))
index 806e903..2e73f84 100644 (file)
@@ -12,13 +12,12 @@ PKG_NAME:=flac
 PKG_VERSION:=1.1.2
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/flac
 PKG_MD5SUM:=2bfc127cdda02834d0491ab531a20960
 PKG_CAT:=zcat
 
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,7 +25,6 @@ define Package/libflac
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=Free Lossless Audio Codec library
-  DESCRIPTION:=Free Lossless Audio Codec (FLAC) library.
   URL:=ttp://flac.sourceforge.net/
 endef
 
@@ -34,19 +32,12 @@ define Build/Configure
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) -f Makefile.lite \
                $(TARGET_CONFIGURE_OPTS) \
                RELEASE_CFLAGS="$(TARGET_CFLAGS)" \
                libFLAC
 endef
 
-define Package/libflac/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/obj/release/lib/libFLAC.so $(1)/usr/lib/
-endef
-
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/include
        $(CP) $(PKG_BUILD_DIR)/include/FLAC $(STAGING_DIR)/usr/include/
@@ -60,4 +51,9 @@ define Build/UninstallDev
                $(STAGING_DIR)/usr/lib/libFLAC.{a,so}
 endef
 
+define Package/libflac/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/obj/release/lib/libFLAC.so $(1)/usr/lib/
+endef
+
 $(eval $(call BuildPackage,libflac))
index 12115fa..7810311 100644 (file)
@@ -35,7 +35,6 @@ define Build/Configure
                --enable-shared \
                --enable-static \
                --disable-rpath \
-               --with-gnu-ld \
                --without-x \
                --without-freetype \
                --with-jpeg=$(STAGING_DIR)/usr \
@@ -65,7 +64,8 @@ define Build/InstallDev
 endef
 
 define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/bin/gdlib-config \
+       rm -rf \
+               $(STAGING_DIR)/usr/bin/gdlib-config \
                $(STAGING_DIR)/usr/include/entities.h \
                $(STAGING_DIR)/usr/include/gd{,_io,cache,fontg,fontl,fontmb,fonts,fontt,fx}.h \
                $(STAGING_DIR)/usr/lib/libgd.{a,so*}
index a993335..a0da70c 100644 (file)
@@ -12,12 +12,12 @@ PKG_NAME:=libamsel
 PKG_VERSION:=20040621-cvs
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.amselinux.net/source/
 PKG_MD5SUM:=2077e620047404881a65d39c53c9917e
 PKG_CAT:=bzcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
@@ -26,8 +26,8 @@ define Package/libamsel
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=The amwall library
-  DESCRIPTION:=The amwall library.\\\
-    A library for amwall configuration files.
+  DESCRIPTION:=\
+       A library for amwall configuration files.
   URL:=http://amselinux.de/
 endef
 
@@ -44,17 +44,12 @@ define Build/Compile
                all install
 endef
 
-define Package/libamsel/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib
-endef
-
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/amsel/compat.h $(STAGING_DIR)/usr/include/
        mkdir -p $(STAGING_DIR)/usr/include/compat
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/amsel/compat/queue.h $(STAGING_DIR)/usr/include/compat
-       mkdir -p $(STAGING_DIR)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/amsel/compat/queue.h $(STAGING_DIR)/usr/include/compat/
+       mkdir -p $(STAGING_DIR)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libamsel.so $(STAGING_DIR)/usr/lib/
 endef
        
@@ -65,4 +60,9 @@ define Build/UninstallDev
                $(STAGING_DIR)/usr/lib/libamsel.so
 endef
 
+define Package/libamsel/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib
+endef
+
 $(eval $(call BuildPackage,libamsel))
index 8539df3..fbf45a0 100644 (file)
@@ -46,7 +46,8 @@ define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
                --enable-static \
-               --with-pf_packet=yes, \
+               --with-pf_packet=yes \
+               , \
                ac_cv_libnet_endianess=$(ENDIANESS) \
                ac_libnet_have_pf_packet=yes \
        )
index 057cc60..a8c2040 100644 (file)
@@ -46,7 +46,8 @@ define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
                --enable-static \
-               --with-pf_packet=yes, \
+               --with-pf_packet=yes \
+               , \
                ac_cv_libnet_endianess=$(ENDIANESS) \
                ac_libnet_have_pf_packet=yes \
                ac_libnet_have_packet_socket=yes \
index faf5c95..13650db 100644 (file)
@@ -12,12 +12,12 @@ PKG_NAME:=libnids
 PKG_VERSION:=1.18
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.packetfactory.net/projects/libnids/dist/
 PKG_MD5SUM:=9ee6dcdfac97bae6fe611aa27d2594a5
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
@@ -35,12 +35,12 @@ endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
-                       --enable-shared \
-                       --enable-static \
-                       --with-libnet="$(STAGING_DIR)/usr/lib/libnet-1.0.x" \
-                       --with-libpcap="$(STAGING_DIR)/usr" \
-                       , \
-                       CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
+               --enable-shared \
+               --enable-static \
+               --with-libnet="$(STAGING_DIR)/usr/lib/libnet-1.0.x" \
+               --with-libpcap="$(STAGING_DIR)/usr" \
+               , \
+               CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
        )
 endef
 
@@ -60,7 +60,8 @@ define Build/InstallDev
 endef
 
 define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/nids.h \
+       rm -rf \
+               $(STAGING_DIR)/usr/include/nids.h \
                $(STAGING_DIR)/usr/lib/libnids.{a,so*}
 endef
 
index 18b04c6..5b64092 100644 (file)
@@ -58,7 +58,7 @@ endef
 
 define Package/liblzo/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblzo2.so.* $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblzo2.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,liblzo))
index 47d5cb4..90c9d18 100644 (file)
@@ -40,10 +40,10 @@ endef
 
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/include/matrixSsl
-       $(CP) $(PKG_BUILD_DIR)/matrixSsl.h $(STAGING_DIR)/usr/include/matrixSsl
+       $(CP) $(PKG_BUILD_DIR)/matrixSsl.h $(STAGING_DIR)/usr/include/matrixSsl/
        ln -sf matrixSsl/matrixSsl.h $(STAGING_DIR)/usr/include/matrixSsl.h
        mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/src/libmatrixssl.so* $(STAGING_DIR)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/src/libmatrixssl.so* $(STAGING_DIR)/usr/lib/
 endef
 
 define Build/UninstallDev
index 1ce9214..7fb1ccb 100644 (file)
@@ -12,12 +12,13 @@ PKG_NAME:=uclibc++
 PKG_VERSION:=0.2.1
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/uClibc++-$(PKG_VERSION)
 PKG_SOURCE:=uClibc++-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://cxx.uclibc.org/src/
 PKG_MD5SUM:=6e6032c49916b199ffe6a585552fd46b
 PKG_CAT:=bzcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/uClibc++-$(PKG_VERSION)
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/uclibcxx
@@ -25,21 +26,20 @@ define Package/uclibcxx
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=C++ library for embedded systems
-  DESCRIPTION:=A standard C++ library for embedded systems
   URL:=http://cxx.uclibc.org/src/
 endef
 
 UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
-                -e 's/i.86/i386/' \
-                -e 's/sparc.*/sparc/' \
-                -e 's/m68k.*/m68k/' \
-                -e 's/ppc/powerpc/g' \
-                -e 's/v850.*/v850/g' \
-                -e 's/sh64/sh/' \
-                -e 's/sh[234].*/sh/' \
-                -e 's/mips.*/mips/' \
-                -e 's/mipsel.*/mips/' \
-                -e 's/cris.*/cris/' \
+       -e 's/i.86/i386/' \
+       -e 's/sparc.*/sparc/' \
+       -e 's/m68k.*/m68k/' \
+       -e 's/ppc/powerpc/g' \
+       -e 's/v850.*/v850/g' \
+       -e 's/sh64/sh/' \
+       -e 's/sh[234].*/sh/' \
+       -e 's/mips.*/mips/' \
+       -e 's/mipsel.*/mips/' \
+       -e 's/cris.*/cris/' \
 )
 
 define Build/Configure
@@ -56,12 +56,6 @@ define Build/Compile
                all
 endef
 
-define Package/uclibcxx/install
-       $(INSTALL_DIR) $(1)/lib
-       $(CP) $(PKG_BUILD_DIR)/src/libuClibc++*.so.* $(1)/lib/
-       $(CP) $(PKG_BUILD_DIR)/src/libuClibc++-*.so $(1)/lib/
-endef
-
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/include
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -77,4 +71,10 @@ define Build/UninstallDev
        rm -rf $(STAGING_DIR)/lib/libuClibc++*.{a,so*}
 endef
 
+define Package/uclibcxx/install
+       $(INSTALL_DIR) $(1)/lib
+       $(CP) $(PKG_BUILD_DIR)/src/libuClibc++*.so.* $(1)/lib/
+       $(CP) $(PKG_BUILD_DIR)/src/libuClibc++-*.so $(1)/lib/
+endef
+
 $(eval $(call BuildPackage,uclibcxx))
index e177744..a1215b0 100644 (file)
@@ -26,8 +26,8 @@ define Package/aircrack-ng
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+libpthread
-  TITLE:=Aircrack-ng the next generation of aircrack with new features
-  URL:=http://www.aircrack-ng.org
+  TITLE:=Aircrack-ng is the next generation of aircrack with new features
+  URL:=http://www.aircrack-ng.org/
 endef
 
 define Build/Configure
@@ -41,7 +41,7 @@ define Build/Compile
                CFLAGS="$(TARGET_CFLAGS) -Wall" \
                prefix="/usr" \
                destdir="$(PKG_INSTALL_DIR)" \
-       all install
+               all install
 endef
 
 define Package/aircrack-ng/install
index 4a1d983..f2c696f 100644 (file)
@@ -27,7 +27,7 @@ define Package/amwall
   CATEGORY:=Network
   DEPENDS:=+libamsel
   TITLE:=PF to iptables
-  URL:=http://www.amselinux.net
+  URL:=http://www.amselinux.net/
 endef
 
 define Build/Compile
@@ -36,7 +36,7 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                V= \
-               LDIR=$(PKG_BUILD_DIR) \
+               LDIR="$(PKG_BUILD_DIR)" \
                AMSEL_INCLUDE="$(STAGING_DIR)/usr/include" \
                OPT_LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
                PREFIX="/usr" \
@@ -47,11 +47,11 @@ endef
 
 define Package/amwall/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/amsel
-       $(CP) $(PKG_INSTALL_DIR)/etc/amsel* $(1)/etc
+       $(CP) $(PKG_INSTALL_DIR)/etc/amsel* $(1)/etc/
 endef
 
 $(eval $(call BuildPackage,amwall))
index 4c5e1d9..03c2a81 100644 (file)
@@ -19,7 +19,6 @@ PKG_CAT:=zcat
 TAR_OPTIONS += || true
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -64,7 +63,7 @@ endef
 
 define Package/atftp/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/atftp $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/atftp $(1)/usr/sbin/
 endef
 
 define Package/atftpd/install
index a58c5cb..8012d7b 100644 (file)
@@ -33,8 +33,8 @@ define Build/Compile
 endef
 
 define Package/bwm/install
-       mkdir -p $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/bwm $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,bwm))
index 2b99a55..1e2f44c 100644 (file)
@@ -18,7 +18,6 @@ PKG_MD5SUM:=50093db9b64277643969ee75b83ebbd1
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -35,13 +34,11 @@ endef
        
 define Build/Compile
        $(TARGET_CC) $(PKG_BUILD_DIR)/cutter.c -o $(PKG_BUILD_DIR)/cutter
-       $(INSTALL_DIR) $(PKG_INSTALL_DIR)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/cutter $(PKG_INSTALL_DIR)/usr/sbin/
 endef
        
 define Package/cutter/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/cutter $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/cutter $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,cutter))
index f7b5799..0dfd624 100644 (file)
@@ -41,7 +41,7 @@ endef
 
 define Package/ethtool/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/ethtool $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,ethtool))
index cdec7c6..9710e15 100644 (file)
@@ -45,8 +45,8 @@ define Build/Compile
 endef
 
 define Package/fprobe-ulog/install     
-       mkdir -p $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/fprobe-ulog $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/fprobe-ulog $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,fprobe-ulog))
index 726445f..2b93068 100644 (file)
@@ -45,7 +45,7 @@ endef
 
 define Package/fprobe/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/fprobe $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/fprobe $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,fprobe))
index 0a26683..2f311fc 100644 (file)
@@ -18,7 +18,6 @@ PKG_MD5SUM:= 5b2e98da2310c71c703d4617b88a173f
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,7 +29,7 @@ define Package/frickin
        Frickin PPTP Proxy allows a Point-to-Point Tunneling Protocol (PPTP) \\\
        client to connect to a PPTP server through Network Address \\\
        Translation (NAT).
-  URL:=http://frickin.sourceforge.net
+  URL:=http://frickin.sourceforge.net/
 endef
 
 define Package/frickin/conffiles
index 883a274..bd6189c 100644 (file)
@@ -29,6 +29,7 @@ define Package/gpsd
   CATEGORY:=Network
   DEPENDS:=+libpthread +uclibcxx
   TITLE:=An interface daemon for GPS receivers
+  URL:=http://gpsd.berlios.de/
 endef
 
 define Build/Configure
index 47b0126..714b32d 100644 (file)
@@ -52,7 +52,7 @@ endef
 
 define Package/iperf/install   
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/iperf $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/iperf $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,iperf))
index 19723bb..c6df3d7 100644 (file)
@@ -30,7 +30,7 @@ define Package/ipkungfu
        IPKungFu is an iptables-based Linux firewall.\\\
        It aims to simplify the configuration of Internet \\\
        connection sharing, port forwarding, and packet filtering.
-  URL:=http://www.linuxkungfu.org
+  URL:=http://www.linuxkungfu.org/
 endef
 
 define Package/ipkungfu/conffiles
index 82f176d..7576681 100644 (file)
@@ -25,8 +25,8 @@ include $(INCLUDE_DIR)/package.mk
 define Package/netperf
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=network performance measurement tool
-  URL:=http://www.netperf.org
+  TITLE:=Network performance measurement tool
+  URL:=http://www.netperf.org/
 endef
 
 define Build/Compile   
index 5aa4ae8..edbe0f4 100644 (file)
@@ -38,7 +38,7 @@ endef
 
 define Package/oidentd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/sbin/
+       $(CP) $(PKG_BUILD_DIR)/src/oidentd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(CP) ./files/oidentd.init $(1)/etc/init.d/oidentd
 endef
index 659ae9e..0481369 100644 (file)
@@ -11,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=privoxy
 PKG_VERSION:=3.0.3
 PKG_RELEASE:=1
-PKG_MD5SUM:=b0710be8af09409bfb03f52523a17010
 
-PKG_SOURCE_URL:=@SF/ijbswa
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable-src.tar.gz
+PKG_SOURCE_URL:=@SF/ijbswa
+PKG_MD5SUM:=b0710be8af09409bfb03f52523a17010
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-stable
@@ -27,12 +27,13 @@ define Package/privoxy
   CATEGORY:=Network
   DEPENDS:=+libpcre +libpthread
   TITLE:=web proxy with advanced filtering capabilities
-  DESCRIPTION:=Privoxy is a web proxy with advanced filtering capabilities for\\\
-       protecting privacy, modifying web page content, managing cookies,\\\
-       controlling access, and removing ads, banners, pop-ups and other\\\
-       obnoxious Internet junk. Privoxy has a very flexible configuration\\\
-       and can be customized to suit individual needs and tastes. Privoxy\\\
-       has application for both stand-alone systems and multi-user networks.\\\
+  DESCRIPTION:=\
+       Privoxy is a web proxy with advanced filtering capabilities for \\\
+       protecting privacy, modifying web page content, managing cookies, \\\
+       controlling access, and removing ads, banners, pop-ups and other \\\
+       obnoxious Internet junk. Privoxy has a very flexible configuration \\\
+       and can be customized to suit individual needs and tastes. Privoxy \\\
+       has application for both stand-alone systems and multi-user networks.
   URL:=http://www.privoxy.org/
 endef
 
index e4c63ed..8f90aa4 100644 (file)
@@ -28,7 +28,7 @@ define Package/reaim
   DEPENDS:=+iptables
   TITLE:=A transparent AIM / MSN proxy
   DESCRIPTION:=ReAIM is a proxy for file transfers with MSN/AIM.
-  URL:=http://reaim.sourceforge.net
+  URL:=http://reaim.sourceforge.net/
 endef
 
 define Build/Compile   
index 0028742..7f3f53d 100644 (file)
@@ -20,7 +20,8 @@ define Package/ttcp
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A TCP connection performance tester
-  DESCRIPTION:=A small utility to test TCP connection performance
+  DESCRIPTION:=\
+       A small utility to test TCP connection performance.
   URL:=https://dev.openwrt.org/browser/packages/net/ttcp/
 endef
 
index 9c97486..b1d3677 100644 (file)
@@ -18,7 +18,6 @@ PKG_MD5SUM:=5951740a8a103d7d9668558b3639c6c4
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
index 90a2b42..5c4aaa7 100644 (file)
@@ -12,12 +12,12 @@ PKG_NAME:=vsftpd
 PKG_VERSION:=2.0.4
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://vsftpd.beasts.org/users/cevans/
 PKG_MD5SUM:=c0bf8c7b8e15ab15827172786fc56115
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
index 798ef59..23144e9 100644 (file)
@@ -29,7 +29,7 @@ define Package/mt-daapd
   TITLE:=A multi-threaded DAAP (Digital Audio Access Protocol) daemon
   DESCRIPTION:=\
        mt-daapd is a program which acts as an iTunes (DAAP) server for Linux.
-  URL:=http://www.mt-daapd.org
+  URL:=http://www.mt-daapd.org/
 endef
 
 define Package/mt-daapd/conffiles
index 1a83d6e..8528b36 100644 (file)
@@ -26,7 +26,7 @@ define Package/mutt
   CATEGORY:=Utilities
   DEPENDS:=+libopenssl +libncurses
   TITLE:=Console mail client
-  URL:=http://www.mutt.org
+  URL:=http://www.mutt.org/
 endef
 
 define Build/Configure