[PATCH] kmod-sound-i8x0 missing dependencies
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 7 Oct 2010 10:12:55 +0000 (10:12 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 7 Oct 2010 10:12:55 +0000 (10:12 +0000)
kmod-sound-i8x0 fails to include the ac97 modules and misspells the
module name in AutoLoad.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23283 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/sound.mk

index 8c0ce65..7b64723 100644 (file)
@@ -102,8 +102,10 @@ endef
 define KernelPackage/sound-i8x0
   TITLE:=Intel/SiS/nVidia/AMD/ALi AC97 Controller
   KCONFIG:=CONFIG_SND_INTEL8X0
-  FILES:=$(LINUX_DIR)/sound/pci/snd-intel8x0.ko
-  AUTOLOAD:=$(call AutoLoad,35,snd-i8x0)
+  FILES:=$(LINUX_DIR)/sound/pci/snd-intel8x0.ko \
+       $(LINUX_DIR)/sound/ac97_bus.ko \
+       $(LINUX_DIR)/sound/pci/ac97/snd-ac97-codec.ko 
+  AUTOLOAD:=$(call AutoLoad,35,ac97_bus snd-ac97-codec snd-intel8x0)
   $(call AddDepends/sound)
 endef