ar71xx: switch to 2.6.32
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 Jan 2010 11:54:24 +0000 (11:54 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 Jan 2010 11:54:24 +0000 (11:54 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19359 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/Makefile
target/linux/ar71xx/patches-2.6.32/003-ar71xx_usb_host.patch
target/linux/ar71xx/patches-2.6.32/110-usb-ehci-add-war-for-synopsys-hc-bug.patch

index b5184b6..4a153e8 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atheros AR71xx/AR7240/AR913x
 FEATURES:=squashfs jffs2 tgz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
-LINUX_VERSION:=2.6.30.10
+LINUX_VERSION:=2.6.32.6
 
 include $(INCLUDE_DIR)/target.mk
 
index 08559bc..0a428c7 100644 (file)
@@ -30,7 +30,7 @@
        depends on USB_OHCI_HCD && (STB03xxx || PPC_MPC52xx)
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -1140,6 +1140,11 @@ MODULE_LICENSE ("GPL");
+@@ -1141,6 +1141,11 @@ MODULE_LICENSE ("GPL");
  #define       PLATFORM_DRIVER         ehci_atmel_driver
  #endif
  
index 91af1ac..18994d0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/usb/host/ehci-q.c
 +++ b/drivers/usb/host/ehci-q.c
-@@ -1167,6 +1167,9 @@ static void end_unlink_async (struct ehc
+@@ -1172,6 +1172,9 @@ static void end_unlink_async (struct ehc
                ehci->reclaim = NULL;
                start_unlink_async (ehci, next);
        }