[package] uhttpd: add "application/x-ns-proxy-autoconfig" mime type (#8236)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Sep 2011 13:28:29 +0000 (13:28 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Sep 2011 13:28:29 +0000 (13:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28149 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/uhttpd/Makefile
package/uhttpd/src/uhttpd-mimetypes.h

index 17823ad..93ac8cf 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=24
+PKG_RELEASE:=25
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_CONFIG_DEPENDS := \
index 032d3d0..21717c0 100644 (file)
@@ -76,6 +76,9 @@ static struct mimetype uh_mime_types[] = {
        { "cfg",     "text/plain" },
        { "conf",    "text/plain" },
 
+       { "pac",                "application/x-ns-proxy-autoconfig" },
+       { "wpad.dat",   "application/x-ns-proxy-autoconfig" },
+
        { NULL, NULL }
 };