tools/squashfs(4): use $(HOSTCC) to avoid building with clang on recent mac os x...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 13 Jul 2012 23:18:15 +0000 (23:18 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 13 Jul 2012 23:18:15 +0000 (23:18 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32706 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/squashfs/Makefile
tools/squashfs4/Makefile

index 473c526..c6ad3dd 100644 (file)
@@ -20,6 +20,7 @@ include $(INCLUDE_DIR)/host-build.mk
 
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
+               CC="$(HOSTCC)" \
                LZMAPATH=$(STAGING_DIR_HOST)/lib \
                mksquashfs-lzma unsquashfs-lzma 
 endef
index 04a5456..fff5502 100644 (file)
@@ -20,6 +20,7 @@ include $(INCLUDE_DIR)/host-build.mk
 
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
+               CC="$(HOSTCC)" \
                XZ_SUPPORT=1 \
                LZMA_XZ_SUPPORT=1 \
                XATTR_SUPPORT= \