libssh2: update to 1.4.3
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Feb 2014 22:47:47 +0000 (22:47 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Feb 2014 22:47:47 +0000 (22:47 +0000)
This patch updates libssh2 to version 1.4.3 and also adds its
pkgconfig file to pkgconfig path.

Signed-off-by: Jiri Slachta <slachta@cesnet.cz>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39496 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libssh2/Makefile

index 01f538f..4410cd3 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libssh2
-PKG_VERSION:=1.4.2
+PKG_VERSION:=1.4.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.libssh2.org/download
-PKG_MD5SUM:=42e2b3796ac07fc1dbafc7abcc002cd3
+PKG_MD5SUM:=071004c60c5d6f90354ad1b701013a0b
 
 PKG_INSTALL:=1
 
@@ -28,7 +28,7 @@ define Package/libssh2
 endef
 
 define Package/libssh2/description
-       libssh2 is a client-side C library implementing the SSH2 protocol
+ libssh2 is a client-side C library implementing the SSH2 protocol.
 endef
 
 TARGET_CFLAGS += $(FPIC)
@@ -40,8 +40,10 @@ CONFIGURE_ARGS += \
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libssh2.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libssh2.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libssh2/install