disable more modules not supported on UML
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 20 Sep 2007 07:46:00 +0000 (07:46 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 20 Sep 2007 07:46:00 +0000 (07:46 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8857 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/video.mk
package/rt2x00/Makefile

index 4a36031..838c4c5 100644 (file)
@@ -11,6 +11,7 @@ VIDEO_MENU:=Video Support
 define KernelPackage/video-core
   SUBMENU:=$(VIDEO_MENU)
   TITLE=Video4Linux support
+  DEPENDS:= @!TARGET_uml
   KCONFIG:= \
        CONFIG_VIDEO_DEV \
        CONFIG_VIDEO_V4L1=y \
index 71cd418..9dd9286 100644 (file)
@@ -29,7 +29,7 @@ endif
 define KernelPackage/rt2x00/Default
   SUBMENU:=Wireless Drivers
   TITLE:=Ralink Drivers for RT2x00 cards
-  DEPENDS:=@LINUX_2_6 @!TARGET_atheros
+  DEPENDS:=@LINUX_2_6 @!TARGET_atheros @!TARGET_uml
   KCONFIG:=CONFIG_MAC80211
 endef