ipv6-support: Add support for NPT status tracking
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 10 Dec 2012 16:46:59 +0000 (16:46 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 10 Dec 2012 16:46:59 +0000 (16:46 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34609 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/ipv6/ipv6-support/Makefile
package/network/ipv6/ipv6-support/files/support.sh

index 97bff4d..a814b52 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipv6-support
-PKG_VERSION:=2012-12-08
+PKG_VERSION:=2012-12-10
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
index 8a0e540..8e8458b 100644 (file)
@@ -134,11 +134,12 @@ announce_prefix() {
        # Always announce the ULA when doing NPT
        [ "$prefix" == "$ula" -a "$prefix_action" == "npt" ] && prefix_action="distribute"
 
-       [ "$prefix_action" == "distribute" ] && {
+       [ "$prefix_action" == "distribute" -o "$prefix_action" == "npt" ] && {
                local msg='{"network": "'"$network"'", "prefix": "'"$addr"'", "length": '"$length"
                [ -n "$valid" ] && msg="$msg"', "valid": '"$valid"', "preferred": '"$prefer"
                [ -z "$cmd" ] && cmd=newprefix
-       
+
+               [ "$prefix_action" == "npt" ] && msg="$msg"', "npt": 1'
                ubus call 6distributed "$cmd" "$msg}"
        }