projects
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6614e4b
)
add depends to the default package template
author
nbd
<nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 27 Jun 2005 10:02:35 +0000
(10:02 +0000)
committer
nbd
<nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 27 Jun 2005 10:02:35 +0000
(10:02 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1291
3c298f89
-4303-0410-b956-
a3cf2f4a3e73
package/rules.mk
patch
|
blob
|
history
diff --git
a/package/rules.mk
b/package/rules.mk
index
6f2573e
..
a95c4e4
100644
(file)
--- a/
package/rules.mk
+++ b/
package/rules.mk
@@
-13,8
+13,11
@@
ifeq ($(BR2_PACKAGE_$(1)),y)
install: $$(INFO_$(1))
endif
+IDEPEND_$(1):=$$(strip $(5))
+
$$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
$(SCRIPT_DIR)/make-ipkg-dir.sh $$(IDIR_$(1)) ./ipkg/$(2).control $(3) $(4)
+ if [ "$$(IDEPEND_$(1))" != "" ]; then echo "Depends: $$(IDEPEND_$(1))" >> $$(IDIR_$(1))/CONTROL/control; fi
for file in conffiles preinst postinst prerm postrm; do \
[ -f ./ipkg/$(2).$$$$file ] && cp ./ipkg/$(2).$$$$file $$(IDIR_$(1))/CONTROL/$$$$file || true; \
done