brcm63xx: convert BTV2500V to dts
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Feb 2015 17:39:29 +0000 (17:39 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Feb 2015 17:39:29 +0000 (17:39 +0000)
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44564 3c298f89-4303-0410-b956-a3cf2f4a3e73

35 files changed:
target/linux/brcm63xx/dts/v2500v-bb.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/511-board_V2500V.patch
target/linux/brcm63xx/patches-3.14/514-board_ct536_ct5621.patch
target/linux/brcm63xx/patches-3.14/516-board_96348A-122.patch
target/linux/brcm63xx/patches-3.14/520-bcm63xx-add-support-for-96368MVWG-board.patch
target/linux/brcm63xx/patches-3.14/521-bcm63xx-add-support-for-96368MVNgr-board.patch
target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch
target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
target/linux/brcm63xx/patches-3.14/528-board_nb6.patch
target/linux/brcm63xx/patches-3.14/529-board_fast2604.patch
target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
target/linux/brcm63xx/patches-3.18/511-board_V2500V.patch
target/linux/brcm63xx/patches-3.18/514-board_ct536_ct5621.patch
target/linux/brcm63xx/patches-3.18/516-board_96348A-122.patch
target/linux/brcm63xx/patches-3.18/520-bcm63xx-add-support-for-96368MVWG-board.patch
target/linux/brcm63xx/patches-3.18/521-bcm63xx-add-support-for-96368MVNgr-board.patch
target/linux/brcm63xx/patches-3.18/526-board_CT6373-1.patch
target/linux/brcm63xx/patches-3.18/527-board_dva-g3810bn-tl-1.patch
target/linux/brcm63xx/patches-3.18/528-board_nb6.patch
target/linux/brcm63xx/patches-3.18/529-board_fast2604.patch
target/linux/brcm63xx/patches-3.18/534-board_hw556.patch
target/linux/brcm63xx/patches-3.18/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.18/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.18/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.18/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.18/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.18/565-board_hw520.patch
target/linux/brcm63xx/profiles/bt.mk [new file with mode: 0644]

diff --git a/target/linux/brcm63xx/dts/v2500v-bb.dts b/target/linux/brcm63xx/dts/v2500v-bb.dts
new file mode 100644 (file)
index 0000000..3959ffb
--- /dev/null
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6348.dtsi"
+
+/ {
+       model = "BT Voyager V2500V";
+       compatible = "bt,v2500v-bb", "brcm,bcm6348";
+};
+
+&pflash {
+       status = "ok";
+
+       linux,part-probe = "bcm63xxpart";
+
+       cfe@0 {
+               label = "CFE";
+               reg = <0x000000 0x010000>;
+               read-only;
+       };
+
+       linux@10000 {
+               label = "linux";
+               reg = <0x010000 0x3e0000>;
+       };
+
+       nvram@3f0000 {
+               label = "nvram";
+               reg = <0x3f0000 0x010000>;
+       };
+};
index d467d8c..0e59ab5 100755 (executable)
@@ -199,9 +199,6 @@ endef
 define Image/Build
        dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
 
-       # BT Voyager V2500V, V2500V_SIP_CLUB, V2500V_AA
-       $(call Image/Build/CFE,$(1),V2500V_BB,6348,BTV2500V,,--layoutver 5)
-
        # build dtb image list
        $(foreach image,$(TARGET_$(PROFILE)_IMAGES),$(call Image/Build/$(image),$(1)))
 
@@ -253,6 +250,8 @@ $(eval $(call ImageDTB,CFEDTB,RG100A,RG100A,rg100a,96358VW2,6358,--block-size 0x
 $(eval $(call ImageDTB,CFEDTB,AR1004G,AR1004G,ar1004g,96348GW-10,6348))
 # Belkin F5D7633
 $(eval $(call ImageDTB,CFEDTB,F5D7633,F5D7633,f5d7633,96348GW-10,6348,--block-size 0x20000 --image-offset 0x20000))
+# BT Voyager V2500V, V2500V_SIP_CLUB, V2500V_AA
+$(eval $(call ImageDTB,CFEDTB,BTV2500V,BTV2500V,v2500v-bb,V2500V_BB,6348,--layoutver 5))
 # Comtrend AR-5381u
 $(eval $(call ImageDTB,CFEDTB,AR5381u,AR-5381u,ar-5381u,96328A-1241N,6328,--pad 8))
 # Comtrend AR-5387un
index e8d7afd..ad5ebd4 100644 (file)
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -1772,6 +1832,22 @@ void __init board_bcm963xx_init(void)
+@@ -1713,6 +1773,7 @@ static struct of_device_id const bcm963x
+       { .compatible = "brcm,bcm96348gw-10", .data = &board_96348gw_10, },
+       { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
+       { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
++      { .compatible = "bt,v2500v-bb", .data = &board_V2500V_BB, },
+       { .compatible = "d-link,dsl-2640b-b", .data = &board_96348_D4PW, },
+       { .compatible = "davolink,dv-201amr", .data = &board_DV201AMR, },
+       { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
+@@ -1772,6 +1833,22 @@ void __init board_bcm963xx_init(void)
                val &= MPI_CSBASE_BASE_MASK;
        }
        boot_addr = (u8 *)KSEG1ADDR(val);
index 3faf0b6..c75e00b 100644 (file)
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -1832,6 +1885,8 @@ static struct of_device_id const bcm963x
-       { .compatible = "brcm,bcm96348gw-10", .data = &board_96348gw_10, },
+@@ -1833,6 +1886,8 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
        { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
+       { .compatible = "bt,v2500v-bb", .data = &board_V2500V_BB, },
 +      { .compatible = "comtrend,ct-536+", .data = &board_ct536_ct5621, },
 +      { .compatible = "comtrend,ct-5621", .data = &board_ct536_ct5621, },
        { .compatible = "d-link,dsl-2640b-b", .data = &board_96348_D4PW, },
index cb1d857..e9375e4 100644 (file)
@@ -85,9 +85,9 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -1889,6 +1960,7 @@ static struct of_device_id const bcm963x
-       { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
+@@ -1890,6 +1961,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
+       { .compatible = "bt,v2500v-bb", .data = &board_V2500V_BB, },
        { .compatible = "comtrend,ct-536+", .data = &board_ct536_ct5621, },
 +      { .compatible = "comtrend,ct-5365", .data = &board_96348A_122, },
        { .compatible = "comtrend,ct-5621", .data = &board_ct536_ct5621, },
index bf1686f..b3a886e 100644 (file)
@@ -107,7 +107,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
  };
  
  static struct of_device_id const bcm963xx_boards_dt[] = {
-@@ -2026,6 +2109,7 @@ static struct of_device_id const bcm963x
+@@ -2027,6 +2110,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6368
index 89e6d98..e4b6508 100644 (file)
@@ -90,7 +90,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
  #endif
  };
  
-@@ -2109,6 +2176,7 @@ static struct of_device_id const bcm963x
+@@ -2110,6 +2177,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6368
index f8ee450..d08822a 100644 (file)
        &board_HW553,
        &board_spw303v,
  #endif
-@@ -2428,6 +2553,7 @@ static struct of_device_id const bcm963x
+@@ -2429,6 +2554,7 @@ static struct of_device_id const bcm963x
        { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
        { .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
        { .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
index 703b2ea..e39e8c4 100644 (file)
@@ -82,7 +82,7 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
-@@ -2556,6 +2624,7 @@ static struct of_device_id const bcm963x
+@@ -2557,6 +2625,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,ct-6373", .data = &board_ct6373_1, },
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
index 61b1f3d..94ad4c9 100644 (file)
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
-@@ -2635,6 +2740,9 @@ static struct of_device_id const bcm963x
+@@ -2636,6 +2741,9 @@ static struct of_device_id const bcm963x
        { .compatible = "t-com,spw303v", .data = &board_spw303v, },
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
index 1bb2131..62d3eb4 100644 (file)
@@ -66,7 +66,7 @@
        &board_DV201AMR,
        &board_96348gw_a,
        &board_rta1025w_16,
-@@ -2716,6 +2768,7 @@ static struct of_device_id const bcm963x
+@@ -2717,6 +2769,7 @@ static struct of_device_id const bcm963x
        { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
        { .compatible = "netgear,dg834gtpn", .data = &board_96348gw_10, },
        { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
index e3c2eec..de672c0 100644 (file)
        &board_spw303v,
        &board_DVAG3810BN,
  #endif
-@@ -3161,6 +3561,9 @@ static struct of_device_id const bcm963x
+@@ -3162,6 +3562,9 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
        { .compatible = "huawei,hg553", .data = &board_HW553, },
index eaf7c56..031bd5e 100644 (file)
@@ -111,7 +111,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
-@@ -3747,6 +3838,7 @@ static struct of_device_id const bcm963x
+@@ -3748,6 +3839,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6362
index 8f84448..94b8778 100644 (file)
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963268bu_p300,
-@@ -4602,6 +4715,7 @@ static struct of_device_id const bcm963x
+@@ -4603,6 +4716,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index 654ec6f..ecc08e2 100644 (file)
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -4715,6 +4826,7 @@ static struct of_device_id const bcm963x
+@@ -4716,6 +4827,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index dd9aa29..7b4ff2b 100644 (file)
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -4827,6 +4938,7 @@ static struct of_device_id const bcm963x
+@@ -4828,6 +4939,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
index c6f3d19..1a173e9 100644 (file)
        &board_VR3025u,
        &board_VR3025un,
        &board_WAP5813n,
-@@ -4940,6 +5031,7 @@ static struct of_device_id const bcm963x
+@@ -4941,6 +5032,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
index 0fa25c3..d28c4af 100644 (file)
@@ -65,7 +65,7 @@
        &board_HW553,
        &board_HW556_A,
        &board_HW556_B,
-@@ -5008,6 +5059,7 @@ static struct of_device_id const bcm963x
+@@ -5009,6 +5060,7 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
index e8d7afd..ad5ebd4 100644 (file)
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -1772,6 +1832,22 @@ void __init board_bcm963xx_init(void)
+@@ -1713,6 +1773,7 @@ static struct of_device_id const bcm963x
+       { .compatible = "brcm,bcm96348gw-10", .data = &board_96348gw_10, },
+       { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
+       { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
++      { .compatible = "bt,v2500v-bb", .data = &board_V2500V_BB, },
+       { .compatible = "d-link,dsl-2640b-b", .data = &board_96348_D4PW, },
+       { .compatible = "davolink,dv-201amr", .data = &board_DV201AMR, },
+       { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
+@@ -1772,6 +1833,22 @@ void __init board_bcm963xx_init(void)
                val &= MPI_CSBASE_BASE_MASK;
        }
        boot_addr = (u8 *)KSEG1ADDR(val);
index 3faf0b6..c75e00b 100644 (file)
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -1832,6 +1885,8 @@ static struct of_device_id const bcm963x
-       { .compatible = "brcm,bcm96348gw-10", .data = &board_96348gw_10, },
+@@ -1833,6 +1886,8 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
        { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
+       { .compatible = "bt,v2500v-bb", .data = &board_V2500V_BB, },
 +      { .compatible = "comtrend,ct-536+", .data = &board_ct536_ct5621, },
 +      { .compatible = "comtrend,ct-5621", .data = &board_ct536_ct5621, },
        { .compatible = "d-link,dsl-2640b-b", .data = &board_96348_D4PW, },
index cb1d857..e9375e4 100644 (file)
@@ -85,9 +85,9 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -1889,6 +1960,7 @@ static struct of_device_id const bcm963x
-       { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
+@@ -1890,6 +1961,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
+       { .compatible = "bt,v2500v-bb", .data = &board_V2500V_BB, },
        { .compatible = "comtrend,ct-536+", .data = &board_ct536_ct5621, },
 +      { .compatible = "comtrend,ct-5365", .data = &board_96348A_122, },
        { .compatible = "comtrend,ct-5621", .data = &board_ct536_ct5621, },
index bf1686f..b3a886e 100644 (file)
@@ -107,7 +107,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
  };
  
  static struct of_device_id const bcm963xx_boards_dt[] = {
-@@ -2026,6 +2109,7 @@ static struct of_device_id const bcm963x
+@@ -2027,6 +2110,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6368
index 89e6d98..e4b6508 100644 (file)
@@ -90,7 +90,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
  #endif
  };
  
-@@ -2109,6 +2176,7 @@ static struct of_device_id const bcm963x
+@@ -2110,6 +2177,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6368
index f8ee450..d08822a 100644 (file)
        &board_HW553,
        &board_spw303v,
  #endif
-@@ -2428,6 +2553,7 @@ static struct of_device_id const bcm963x
+@@ -2429,6 +2554,7 @@ static struct of_device_id const bcm963x
        { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
        { .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
        { .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
index 703b2ea..e39e8c4 100644 (file)
@@ -82,7 +82,7 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
-@@ -2556,6 +2624,7 @@ static struct of_device_id const bcm963x
+@@ -2557,6 +2625,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,ct-6373", .data = &board_ct6373_1, },
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
index 61b1f3d..94ad4c9 100644 (file)
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
-@@ -2635,6 +2740,9 @@ static struct of_device_id const bcm963x
+@@ -2636,6 +2741,9 @@ static struct of_device_id const bcm963x
        { .compatible = "t-com,spw303v", .data = &board_spw303v, },
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
index 1bb2131..62d3eb4 100644 (file)
@@ -66,7 +66,7 @@
        &board_DV201AMR,
        &board_96348gw_a,
        &board_rta1025w_16,
-@@ -2716,6 +2768,7 @@ static struct of_device_id const bcm963x
+@@ -2717,6 +2769,7 @@ static struct of_device_id const bcm963x
        { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
        { .compatible = "netgear,dg834gtpn", .data = &board_96348gw_10, },
        { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
index e3c2eec..de672c0 100644 (file)
        &board_spw303v,
        &board_DVAG3810BN,
  #endif
-@@ -3161,6 +3561,9 @@ static struct of_device_id const bcm963x
+@@ -3162,6 +3562,9 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
        { .compatible = "huawei,hg553", .data = &board_HW553, },
index eaf7c56..031bd5e 100644 (file)
@@ -111,7 +111,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
-@@ -3747,6 +3838,7 @@ static struct of_device_id const bcm963x
+@@ -3748,6 +3839,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6362
index 8f84448..94b8778 100644 (file)
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963268bu_p300,
-@@ -4602,6 +4715,7 @@ static struct of_device_id const bcm963x
+@@ -4603,6 +4716,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index 654ec6f..ecc08e2 100644 (file)
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -4715,6 +4826,7 @@ static struct of_device_id const bcm963x
+@@ -4716,6 +4827,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index dd9aa29..7b4ff2b 100644 (file)
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -4827,6 +4938,7 @@ static struct of_device_id const bcm963x
+@@ -4828,6 +4939,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
index c6f3d19..1a173e9 100644 (file)
        &board_VR3025u,
        &board_VR3025un,
        &board_WAP5813n,
-@@ -4940,6 +5031,7 @@ static struct of_device_id const bcm963x
+@@ -4941,6 +5032,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
index 0fa25c3..d28c4af 100644 (file)
@@ -65,7 +65,7 @@
        &board_HW553,
        &board_HW556_A,
        &board_HW556_B,
-@@ -5008,6 +5059,7 @@ static struct of_device_id const bcm963x
+@@ -5009,6 +5060,7 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
diff --git a/target/linux/brcm63xx/profiles/bt.mk b/target/linux/brcm63xx/profiles/bt.mk
new file mode 100644 (file)
index 0000000..0863752
--- /dev/null
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/BTV2500V
+  NAME:=BT Voyager V2500V
+  PACKAGES:=kmod-b43 wpad-mini
+endef
+define Profile/BTV2500V/Description
+  Package set optimized for BTV2500V.
+endef
+$(eval $(call Profile,BTV2500V))