ltq-ifxos: only attempt to build if the lantiq target is selected (fixes #9035)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Mar 2011 18:45:27 +0000 (18:45 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Mar 2011 18:45:27 +0000 (18:45 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26132 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/ltq-ifxos/Makefile

index 518c90f..c947404 100644 (file)
@@ -39,11 +39,13 @@ define Build/Configure
        $(call Build/Configure/Default)
 endef
 
-define Build/InstallDev
+ifdef CONFIG_TARGET_lantiq
+  define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/{lib,include/ifxos}
        $(CP) $(PKG_BUILD_DIR)/src/include/* $(1)/usr/include/ifxos
        mkdir -p $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/src/libifxos.a $(1)/usr/lib/libifxos.a
-endef
+  endef
+endif
 
 $(eval $(call KernelPackage,ltq-ifxos))