base-files: remove duplicate stop_service() function.
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 Apr 2014 18:48:57 +0000 (18:48 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 Apr 2014 18:48:57 +0000 (18:48 +0000)
It was introduced in commit 2f966e8, "base-files: add a post start hook
for procd managed services".

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40576 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/etc/rc.common

index d0366ee..207af35 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=151
+PKG_RELEASE:=152
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 1984db9..829ec76 100755 (executable)
@@ -92,10 +92,6 @@ service_running() {
        return 0
 }
 
-stop_service() {
-       return 0
-}
-
 ${INIT_TRACE:+set -x}
 
 . "$initscript"