sound/mpd: update to mpd 0.16.8
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Feb 2014 18:04:03 +0000 (18:04 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Feb 2014 18:04:03 +0000 (18:04 +0000)
updating to latest mpd requres more work on dependencies
(libmms,libaudiofile,libstdcpp)

- mpd isn't hosted on sourceforge anymore

- fix: #14422
Issue 1: could not replicate
Issue 2: update to last mpd 0.16 series fixes compile,
its linked to ffmpeg version

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39540 3c298f89-4303-0410-b956-a3cf2f4a3e73

sound/mpd/Makefile
sound/mpd/patches/100-compile-fixes.patch

index 19f9b06..baa8059 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpd
-PKG_VERSION:=0.16.5
+PKG_VERSION:=0.16.8
 PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/musicpd
-PKG_MD5SUM:=f7564cff12035f6a1112cce770655df7
+PKG_SOURCE_URL:=http://www.musicpd.org/download/mpd/0.16/
+PKG_MD5SUM:=b412a9d0b3457bea1bb87904a8f80c04
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_BUILD_PARALLEL:=1
index cd05159..60b8b01 100644 (file)
@@ -1,8 +1,6 @@
-Index: mpd-0.16.1/configure
-===================================================================
---- mpd-0.16.1.orig/configure  2011-01-10 02:58:36.000000000 +0100
-+++ mpd-0.16.1/configure       2011-03-10 13:01:31.000000000 +0100
-@@ -8718,6 +8718,7 @@
+--- a/configure
++++ b/configure
+@@ -8803,6 +8803,7 @@ fi
  # Check whether --with-faad was given.
  if test "${with_faad+set}" = set; then :
    withval=$with_faad;
@@ -10,11 +8,9 @@ Index: mpd-0.16.1/configure
  else
    faad_prefix=""
  fi
-Index: mpd-0.16.1/src/input/file_input_plugin.c
-===================================================================
---- mpd-0.16.1.orig/src/input/file_input_plugin.c      2011-01-10 02:58:08.000000000 +0100
-+++ mpd-0.16.1/src/input/file_input_plugin.c   2011-03-10 13:02:15.000000000 +0100
-@@ -79,10 +79,6 @@
+--- a/src/input/file_input_plugin.c
++++ b/src/input/file_input_plugin.c
+@@ -79,10 +79,6 @@ input_file_open(const char *filename, GE
                return false;
        }