gcc: make colors optional based on the GCC_COLORS env var
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 25 Nov 2015 14:12:44 +0000 (14:12 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 25 Nov 2015 14:12:44 +0000 (14:12 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47642 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/gcc/common.mk

index 0ac7de1..3e4f3ee 100644 (file)
@@ -151,6 +151,10 @@ ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
   GCC_CONFIGURE += --with-mips-plt
 endif
 
+ifndef GCC_VERSION_4_8
+  GCC_CONFIGURE += --with-diagnostics-color=auto-if-env
+endif
+
 ifneq ($(CONFIG_SSP_SUPPORT),)
   GCC_CONFIGURE+= \
                --enable-libssp