Allow downloading of files with undefined mdsum (to ease updating packages)
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 21 May 2005 10:57:17 +0000 (10:57 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 21 May 2005 10:57:17 +0000 (10:57 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1005 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/rules.mk

index 51be458..03b750f 100644 (file)
@@ -29,7 +29,7 @@ endef
 
 ifneq ($(strip $(PKG_SOURCE)),)
 $(DL_DIR)/$(PKG_SOURCE):
-       $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+       $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_SOURCE)" "$(PKG_MD5SUM)" $(PKG_SOURCE_URL)
 endif
 
 ifneq ($(strip $(PKG_CAT)),)