Add fastcgi subpackage (Thanks aorlinsk for the help)
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 4 Jul 2005 12:11:08 +0000 (12:11 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 4 Jul 2005 12:11:08 +0000 (12:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1331 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/lighttpd/Config.in
package/lighttpd/Makefile
package/lighttpd/ipkg/lighttpd-mod-fastcgi.control [new file with mode: 0644]

index fd42335..f1b7f1e 100644 (file)
@@ -32,6 +32,12 @@ config BR2_PACKAGE_LIGHTTPD_MOD_CGI
        tristate 
        default m if CONFIG_DEVEL
 
+config BR2_PACKAGE_LIGHTTPD_MOD_FASTCGI
+       depends BR2_PACKAGE_LIGHTTPD
+       prompt "...-mod-fastcgi - FastCGI module"
+       tristate 
+       default m if CONFIG_DEVEL
+
 config BR2_PACKAGE_LIGHTTPD_MOD_PROXY
        depends BR2_PACKAGE_LIGHTTPD
        prompt "...-mod-proxy - Proxy module"
index 38aaa85..df6a7df 100644 (file)
@@ -30,6 +30,7 @@ $(eval $(call PKG_template,LIGHTTPD,lighttpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARC
 $(eval $(call PKG_template,LIGHTTPD_MOD_ALIAS,lighttpd-mod-alias,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_AUTH,lighttpd-mod-auth,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_CGI,lighttpd-mod-cgi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LIGHTTPD_MOD_FASTCGI,lighttpd-mod-fastcgi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_PROXY,lighttpd-mod-proxy,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_REDIRECT,lighttpd-mod-redirect,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_REWRITE,lighttpd-mod-rewrite,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -41,6 +42,7 @@ $(eval $(call PKG_template,LIGHTTPD_MOD_USERTRACK,lighttpd-mod-usertrack,$(PKG_V
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_ALIAS,alias))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_AUTH,auth))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_CGI,cgi))
+$(eval $(call PKG_mod_template,LIGHTTPD_MOD_FASTCGI,fastcgi))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_PROXY,proxy))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_REDIRECT,redirect))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_REWRITE,rewrite))
diff --git a/package/lighttpd/ipkg/lighttpd-mod-fastcgi.control b/package/lighttpd/ipkg/lighttpd-mod-fastcgi.control
new file mode 100644 (file)
index 0000000..e653e95
--- /dev/null
@@ -0,0 +1,9 @@
+Package: lighttpd-mod-fastcgi
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Anael Orlinski <anael.orlinski@gmail.com>, Nico <nthill@free.fr>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/lighttpd/
+Description: FASTCGI module for lighttpd
+Depends: lighttpd