add cifs, disable smbfs
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Mar 2005 19:46:56 +0000 (19:46 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Mar 2005 19:46:56 +0000 (19:46 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@413 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/linux/Config.in
openwrt/package/linux/Makefile
openwrt/package/linux/control/kmod-cifs.control [new file with mode: 0644]
openwrt/package/linux/control/kmod-smbfs.control [deleted file]
openwrt/package/linux/kernel-patches/305-cifs-1.20c.bz2 [new file with mode: 0644]
openwrt/package/linux/linux.config
openwrt/package/linux/linux.mk

index 3a77a42..1275b21 100644 (file)
@@ -36,11 +36,11 @@ config BR2_PACKAGE_KMOD_NFS
          Kernel modules for NFS support
          Includes lockd, nfs and sunrpc
 
-config BR2_PACKAGE_KMOD_SMBFS
-       tristate "SMB support"
+config BR2_PACKAGE_KMOD_CIFS
+       tristate "CIFS support"
        default m
        help
-         Kernel modules for SMB support
+         Kernel modules for CIFS support
 
 config BR2_PACKAGE_KMOD_USB
        tristate "USB/SCSI support"
index 5c74d39..73f8214 100644 (file)
@@ -53,9 +53,9 @@ $(eval $(call KMOD_template,IPT6,ip6tables,\
 $(eval $(call KMOD_template,IPV6,ipv6,\
        $(MODULES_DIR)/kernel/net/ipv6/ipv6.o \
 ,CONFIG_IPV6))
-$(eval $(call KMOD_template,SMBFS,smbfs,\
-       $(MODULES_DIR)/kernel/fs/smbfs/smbfs.o \
-,CONFIG_SMB_FS))
+$(eval $(call KMOD_template,CIFS,cifs,\
+       $(MODULES_DIR)/kernel/fs/cifs/cifs.o \
+,CONFIG_CIFS))
 $(eval $(call KMOD_template,NFS,nfs,\
        $(MODULES_DIR)/kernel/fs/lockd/*.o \
        $(MODULES_DIR)/kernel/fs/nfs/*.o \
diff --git a/openwrt/package/linux/control/kmod-cifs.control b/openwrt/package/linux/control/kmod-cifs.control
new file mode 100644 (file)
index 0000000..a70063d
--- /dev/null
@@ -0,0 +1,8 @@
+Package: kmod-cifs
+Priority: optional
+Section: sys
+Version: 2.4.29-1
+Architecture: mipsel
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: Kernel modules for CIFS support
diff --git a/openwrt/package/linux/control/kmod-smbfs.control b/openwrt/package/linux/control/kmod-smbfs.control
deleted file mode 100644 (file)
index cf8b46e..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-Package: kmod-smbfs
-Priority: optional
-Section: sys
-Version: 2.4.29-1
-Architecture: mipsel
-Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
-Source: buildroot internal
-Description: Kernel modules for SMB support
diff --git a/openwrt/package/linux/kernel-patches/305-cifs-1.20c.bz2 b/openwrt/package/linux/kernel-patches/305-cifs-1.20c.bz2
new file mode 100644 (file)
index 0000000..41d835a
Binary files /dev/null and b/openwrt/package/linux/kernel-patches/305-cifs-1.20c.bz2 differ
index 31900bb..34cc65e 100644 (file)
@@ -891,9 +891,10 @@ CONFIG_NFS_V3=y
 CONFIG_SUNRPC=m
 CONFIG_LOCKD=m
 CONFIG_LOCKD_V4=y
-CONFIG_SMB_FS=m
-# CONFIG_SMB_NLS_DEFAULT is not set
-# CONFIG_SMB_UNIX is not set
+CONFIG_CIFS=m
+# CONFIG_CIFS_STATS is not set
+CONFIG_CIFS_POSIX=y
+# CONFIG_SMB_FS is not set
 # CONFIG_NCP_FS is not set
 # CONFIG_NCPFS_PACKET_SIGNING is not set
 # CONFIG_NCPFS_IOCTL_LOCKING is not set
@@ -924,7 +925,7 @@ CONFIG_MSDOS_PARTITION=y
 # CONFIG_ULTRIX_PARTITION is not set
 # CONFIG_SUN_PARTITION is not set
 # CONFIG_EFI_PARTITION is not set
-CONFIG_SMB_NLS=y
+# CONFIG_SMB_NLS is not set
 CONFIG_NLS=y
 
 #
index 322adad..02cc3bb 100644 (file)
@@ -112,4 +112,6 @@ linux-dirclean:
        rm -rf $(LINUX_DIR)-$(LINUX_VERSION)
        rm -rf $(LINUX_DIR)
        rm -rf $(BUILD_DIR)/modules
+       rm -rf $(BUILD_DIR)/wl
+       rm -rf $(BUILD_DIR)/et