[package] base-files: respect .auto option when running coldplug_interface_*() hooks...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 27 May 2010 23:04:56 +0000 (23:04 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 27 May 2010 23:04:56 +0000 (23:04 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21588 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/etc/init.d/network

index 1a92a59..9eab5e5 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=44
+PKG_RELEASE:=45
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index d60d41a..9d4904a 100755 (executable)
@@ -23,7 +23,10 @@ boot() {
                local proto
                config_get proto "$ifc" proto
 
-               type "coldplug_interface_$proto" >/dev/null && \
+               local auto
+               config_get_bool auto "$ifc" auto 1
+
+               type "coldplug_interface_$proto" >/dev/null && [ "$auto" = 1 ] && \
                        coldplug_interface_$proto "$ifc"
        done
 }