[kernel] Add package for gpio-pwm
authorclaudio <claudio@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 12 Jul 2010 13:20:01 +0000 (13:20 +0000)
committerclaudio <claudio@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 12 Jul 2010 13:20:01 +0000 (13:20 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22143 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/other.mk

index 0716459..9b8259b 100644 (file)
@@ -661,3 +661,19 @@ define KernelPackage/wdt-scx200/description
 endef
 
 $(eval $(call KernelPackage,wdt-scx200))
+
+
+define KernelPackage/pwm-gpio
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=PWM over GPIO
+  KCONFIG:=CONFIG_GENERIC_PWM \
+               CONFIG_GPIO_PWM
+  FILES:=$(LINUX_DIR)/drivers/pwm/gpio-pwm.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,51,gpio-pwm)
+endef
+
+define KernelPackage/pwm-gpio/description
+ Kernel module to models a single-channel PWM device using a timer and a GPIO pin
+endef
+
+$(eval $(call KernelPackage,pwm-gpio))