iwinfo: fix frequency/channel and channel/frequency conversions to properly implement...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 9 Apr 2013 14:37:55 +0000 (14:37 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 9 Apr 2013 14:37:55 +0000 (14:37 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36292 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/iwinfo/Makefile
package/network/utils/iwinfo/src/iwinfo_nl80211.c

index f8a92da..23f3f38 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiwinfo
-PKG_RELEASE:=39
+PKG_RELEASE:=40
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_CONFIG_DEPENDS := \
index 819845a..2a2bb66 100644 (file)
@@ -346,23 +346,30 @@ static int nl80211_freq2channel(int freq)
 {
        if (freq == 2484)
                return 14;
-
-       if (freq < 2484)
+       else if (freq < 2484)
                return (freq - 2407) / 5;
-
-       return (freq / 5) - 1000;
+       else if (freq >= 4910 && freq <= 4980)
+               return (freq - 4000) / 5;
+       else
+               return (freq - 5000) / 5;
 }
 
 static int nl80211_channel2freq(int channel, const char *band)
 {
-       if (channel == 14)
-               return 2484;
-
-       if ((channel < 14) && (!band || band[0] != 'a'))
-               return (channel * 5) + 2407;
-
-       if (channel > 0)
-               return (1000 + channel) * 5;
+       if (!band || band[0] != 'a')
+       {
+               if (channel == 14)
+                       return 2484;
+               else if (channel < 14)
+                       return (channel * 5) + 2407;
+       }
+       else
+       {
+               if (channel >= 182 && channel <= 196)
+                       return (channel * 5) + 4000;
+               else
+                       return (channel * 5) + 5000;
+       }
 
        return 0;
 }