kernel: kmod-ptp selects a new config symbol
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 17 Dec 2015 09:29:34 +0000 (09:29 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 17 Dec 2015 09:29:34 +0000 (09:29 +0000)
since Kernel 3.14
408eccce net: ptp: move PTP classifier in its own file

found while bug search
thx olmari on IRC

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47923 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/other.mk

index 9bb9dec..62fdc3c 100644 (file)
@@ -820,7 +820,9 @@ define KernelPackage/ptp
   SUBMENU:=$(OTHER_MENU)
   TITLE:=PTP clock support
   DEPENDS:=+kmod-pps
-  KCONFIG:=CONFIG_PTP_1588_CLOCK
+  KCONFIG:= \
+       CONFIG_PTP_1588_CLOCK \
+       CONFIG_NET_PTP_CLASSIFY=y
   FILES:=$(LINUX_DIR)/drivers/ptp/ptp.ko
   AUTOLOAD:=$(call AutoLoad,18,ptp,1)
 endef