ipv6-support: Fix default RA settings for dnsmasq
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 23 Dec 2012 18:22:48 +0000 (18:22 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 23 Dec 2012 18:22:48 +0000 (18:22 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34873 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/ipv6/ipv6-support/Makefile
package/network/ipv6/ipv6-support/files/support.sh

index 6bc3f79..76c97c2 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipv6-support
-PKG_VERSION:=2012-12-22
+PKG_VERSION:=2012-12-23
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
index 8cd044f..261ff1e 100644 (file)
@@ -438,12 +438,12 @@ enable_router() {
 
        if [ "$router_service" == "dnsmasq" ]; then
                local dnsmasq_opts
-               config_get dnsmasq_opts global dnsmasq_opts
-               [ -z "$dnsmasq_opts" ] && dnsmasq_opts="ra-stateful,ra-names"
+               config_get dnsmasq_opts "$network" dnsmasq_opts
+               [ -z "$dnsmasq_opts" ] && dnsmasq_opts="ra-names,24h"
 
                local conf="/var/etc/dnsmasq.d/ipv6-router-$network.conf"
                mkdir -p $(dirname $conf)
-               echo "dhcp-range=::1,constructor:$device,$dnsmasq_opts" > $conf
+               echo "dhcp-range=::00ff,::ffff,constructor:$device,$dnsmasq_opts" > $conf
                echo "enable-ra" >> $conf
                /etc/init.d/dnsmasq restart
        else