6in4: make host dependency more specific
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Mar 2015 08:43:40 +0000 (08:43 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Mar 2015 08:43:40 +0000 (08:43 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44635 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/ipv6/6in4/Makefile
package/network/ipv6/6in4/files/6in4.sh

index ef96912..21e69e6 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=20
+PKG_VERSION:=21
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-2.0
 
index f8a43ce..0289df3 100755 (executable)
@@ -36,7 +36,7 @@ proto_6in4_setup() {
                return
        }
 
-       ( proto_add_host_dependency "$cfg" 0.0.0.0 )
+       ( proto_add_host_dependency "$cfg" "$peeraddr" )
 
        [ -z "$ipaddr" ] && {
                local wanif