don't copy initramfs.elf unconditionally
authorImre Kaloz <kaloz@openwrt.org>
Fri, 26 Dec 2014 14:31:45 +0000 (14:31 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Fri, 26 Dec 2014 14:31:45 +0000 (14:31 +0000)
targets that need it should do it in their image Makefile

Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43780 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index f9b8998..d6c8b7a 100644 (file)
@@ -89,7 +89,6 @@ define prepare_generic_squashfs
 endef
 
 define Image/BuildKernel/Initramfs
-       cp $(KDIR)/vmlinux-initramfs.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs.elf
        $(call Image/Build/Initramfs)
 endef