Added mini-http-htpasswd package, closes request #251
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Feb 2006 21:55:53 +0000 (21:55 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Feb 2006 21:55:53 +0000 (21:55 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3129 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/mini_httpd/Config.in
package/mini_httpd/Makefile
package/mini_httpd/ipkg/mini-httpd-htpasswd.control [new file with mode: 0644]

index 7b90881..9946633 100644 (file)
@@ -31,6 +31,14 @@ config BR2_PACKAGE_MINI_HTTPD
          
          http://www.acme.com/software/mini_httpd/
 
+config BR2_PACKAGE_MINI_HTTPD_HTPASSWD
+       prompt "mini-httpd-htpasswd............... Utility to generate HTTP access files"
+       tristate
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_MINI_HTTPD
+       help
+               This file generates .htaccess/.htpasswd files to use HTTP access                authentication
+
 config BR2_PACKAGE_MINI_HTTPD_MATRIXSSL
        prompt "mini-httpd-matrixssl.............. A small web server, built with SSL support using MatrixSSL"
        tristate
index 053ac91..da976ef 100644 (file)
@@ -16,6 +16,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/mini_httpd-$(PKG_VERSION)
 include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,MINI_HTTPD,mini-httpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,MINI_HTTPD_HTPASSWD,mini-httpd-htpasswd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,MINI_HTTPD_MATRIXSSL,mini-httpd-matrixssl,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,MINI_HTTPD_OPENSSL,mini-httpd-openssl,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
@@ -71,6 +72,12 @@ $(IPKG_MINI_HTTPD):
        $(RSTRIP) $(IDIR_MINI_HTTPD)
        $(IPKG_BUILD) $(IDIR_MINI_HTTPD) $(PACKAGE_DIR)
 
+$(IPKG_MINI_HTTPD_HTPASSWD):
+       install -d -m0755 $(IDIR_MINI_HTTPD_HTPASSWD)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/htpasswd $(IDIR_MINI_HTTPD_HTPASSWD)/usr/sbin/
+       $(RSTRIP) $(IDIR_MINI_HTTPD_HTPASSWD)
+       $(IPKG_BUILD) $(IDIR_MINI_HTTPD_HTPASSWD) $(PACKAGE_DIR)
+
 $(IPKG_MINI_HTTPD_MATRIXSSL):
        install -d -m0755 $(IDIR_MINI_HTTPD_MATRIXSSL)/etc
        install -m0644 ./files/mini_httpd-ssl.conf $(IDIR_MINI_HTTPD_MATRIXSSL)/etc/mini_httpd.conf
diff --git a/package/mini_httpd/ipkg/mini-httpd-htpasswd.control b/package/mini_httpd/ipkg/mini-httpd-htpasswd.control
new file mode 100644 (file)
index 0000000..6b80aa6
--- /dev/null
@@ -0,0 +1,4 @@
+Package: mini-httpd-htpasswd
+Priority: optional
+Section: net
+Description: utility to generate HTTP access authentication files