toolchain-headers: also copy asm-eva.h for mips(el) for 3.15+
authorJonas Gorski <jogo@openwrt.org>
Mon, 1 Dec 2014 13:27:06 +0000 (13:27 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 1 Dec 2014 13:27:06 +0000 (13:27 +0000)
Kernel 3.15's asm.h includes eva-asm.h, so copy it also, else lzma-loader
won't compile due to a missing include.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43460 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/kernel-headers/Makefile

index 9427f82..d93a123 100644 (file)
@@ -57,6 +57,7 @@ ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
        $(CP) \
                $(HOST_BUILD_DIR)/arch/mips/include/asm/asm.h \
                $(HOST_BUILD_DIR)/arch/mips/include/asm/regdef.h \
+               $(if $(call kernel_patchver_ge,3.15.0),$(HOST_BUILD_DIR)/arch/mips/include/asm/asm-eva.h) \
                $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/asm/
   endef
 endif