[package] i2c-gpio-mux: fix build for 3.6+ kernels
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 11 Nov 2012 18:40:43 +0000 (18:40 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 11 Nov 2012 18:40:43 +0000 (18:40 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34152 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/i2c.mk

index 6c65989..49d8250 100644 (file)
@@ -197,8 +197,13 @@ endef
 
 $(eval $(call KernelPackage,i2c-mux))
 
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.6.0)),1)
+I2C_MUX_GPIO_MODULES:= \
+  CONFIG_I2C_MUX_GPIO:drivers/i2c/muxes/i2c-mux-gpio
+else
 I2C_MUX_GPIO_MODULES:= \
   CONFIG_I2C_MUX_GPIO:drivers/i2c/muxes/gpio-i2cmux
+endif
 
 define KernelPackage/i2c-mux-gpio
   $(call i2c_defaults,$(I2C_MUX_GPIO_MODULES),51)