[adm8668] enable and advertise USB support
authorFlorian Fainelli <florian@openwrt.org>
Thu, 6 Dec 2012 22:40:54 +0000 (22:40 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 6 Dec 2012 22:40:54 +0000 (22:40 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34562 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/adm8668/Makefile
target/linux/adm8668/config-3.3

index 8ad2e71..4e49332 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=adm8668
 BOARDNAME:=Infineon WildPass ADM8668
-FEATURES:=squashfs
+FEATURES:=squashfs usb pci
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 LINUX_VERSION:=3.3.8
index b365db1..169245d 100644 (file)
@@ -94,5 +94,9 @@ CONFIG_TULIP_NAPI=y
 # CONFIG_TULIP_PCI is not set
 CONFIG_TULIP_PLATFORM=y
 # CONFIG_ULI526X is not set
+CONFIG_USB_ARCH_HAS_XHCI=y
+# CONFIG_USB_HCD_BCMA is not set
+# CONFIG_USB_HCD_SSB is not set
+CONFIG_USB_SUPPORT=y
 # CONFIG_WINBOND_840 is not set
 CONFIG_ZONE_DMA_FLAG=0