generic/4.0: refresh patches
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 Feb 2015 18:53:14 +0000 (18:53 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 Feb 2015 18:53:14 +0000 (18:53 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44532 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/generic/patches-4.0/305-mips_module_reloc.patch
target/linux/generic/patches-4.0/491-ubi-auto-create-ubiblock-device-for-rootfs.patch
target/linux/generic/patches-4.0/604-netfilter_conntrack_flush.patch
target/linux/generic/patches-4.0/617-netfilter_skip_filter_sysctl.patch
target/linux/generic/patches-4.0/645-bridge_multicast_to_unicast.patch
target/linux/generic/patches-4.0/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
target/linux/generic/patches-4.0/862-gpio_spi_driver.patch

index 2e92916..752d597 100644 (file)
  {
 +#ifdef MODULE_START
        return __vmalloc_node_range(size, 1, MODULE_START, MODULE_END,
-                               GFP_KERNEL, PAGE_KERNEL, NUMA_NO_NODE,
+                               GFP_KERNEL, PAGE_KERNEL, 0, NUMA_NO_NODE,
                                __builtin_return_address(0));
 +#else
 +      void *ptr;
index c0ee1f7..07562b2 100644 (file)
@@ -11,8 +11,8 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
 
 --- a/drivers/mtd/ubi/block.c
 +++ b/drivers/mtd/ubi/block.c
-@@ -614,6 +614,44 @@ static int __init ubiblock_create_from_p
-       return ret;
+@@ -614,6 +614,44 @@ static void __init ubiblock_create_from_
+       }
  }
  
 +#define UBIFS_NODE_MAGIC  0x06101831
@@ -57,8 +57,8 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  {
        struct ubiblock *next;
 @@ -644,6 +682,10 @@ int __init ubiblock_init(void)
-       if (ret)
-               goto err_remove;
+        */
+       ubiblock_create_from_param();
  
 +      /* auto-attach "rootfs" volume if existing and non-ubifs */
 +      if (config_enabled(CONFIG_MTD_ROOTFS_ROOT_DEV))
index bd7a7ff..6d58189 100644 (file)
@@ -8,7 +8,7 @@
  #include <net/net_namespace.h>
  #ifdef CONFIG_SYSCTL
  #include <linux/sysctl.h>
-@@ -259,10 +260,66 @@ static int ct_open(struct inode *inode,
+@@ -265,10 +266,66 @@ static int ct_open(struct inode *inode,
                        sizeof(struct ct_iter_state));
  }
  
@@ -75,7 +75,7 @@
        .llseek  = seq_lseek,
        .release = seq_release_net,
  };
-@@ -364,7 +421,7 @@ static int nf_conntrack_standalone_init_
+@@ -370,7 +427,7 @@ static int nf_conntrack_standalone_init_
  {
        struct proc_dir_entry *pde;
  
index 5d67818..6cf6568 100644 (file)
@@ -63,7 +63,7 @@
                             net->ipv6.ip6table_filter);
 --- a/net/netfilter/nf_conntrack_standalone.c
 +++ b/net/netfilter/nf_conntrack_standalone.c
-@@ -501,6 +501,13 @@ static struct ctl_table nf_ct_sysctl_tab
+@@ -507,6 +507,13 @@ static struct ctl_table nf_ct_sysctl_tab
                .extra2         = &log_invalid_proto_max,
        },
        {
@@ -77,7 +77,7 @@
                .procname       = "nf_conntrack_expect_max",
                .data           = &nf_ct_expect_max,
                .maxlen         = sizeof(int),
-@@ -536,6 +543,7 @@ static int nf_conntrack_standalone_init_
+@@ -542,6 +549,7 @@ static int nf_conntrack_standalone_init_
        table[2].data = &net->ct.htable_size;
        table[3].data = &net->ct.sysctl_checksum;
        table[4].data = &net->ct.sysctl_log_invalid;
index fb5c389..f09875c 100644 (file)
  };
  
  struct net_bridge_mdb_entry
-@@ -476,7 +479,8 @@ void br_multicast_free_pg(struct rcu_hea
+@@ -480,7 +483,8 @@ void br_multicast_free_pg(struct rcu_hea
  struct net_bridge_port_group *
  br_multicast_new_port_group(struct net_bridge_port *port, struct br_ip *group,
                            struct net_bridge_port_group __rcu *next,
  void br_mdb_notify(struct net_device *dev, struct net_bridge_port *port,
 --- a/net/bridge/br_mdb.c
 +++ b/net/bridge/br_mdb.c
-@@ -342,7 +342,7 @@ static int br_mdb_add_group(struct net_b
+@@ -343,7 +343,7 @@ static int br_mdb_add_group(struct net_b
                        break;
        }
  
index 230c808..cf5737d 100644 (file)
@@ -472,7 +472,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        return 0;
  
  nla_put_failure:
-@@ -1769,6 +2022,7 @@ static const struct nla_policy ip6_tnl_p
+@@ -1777,6 +2030,7 @@ static const struct nla_policy ip6_tnl_p
        [IFLA_IPTUN_FLOWINFO]           = { .type = NLA_U32 },
        [IFLA_IPTUN_FLAGS]              = { .type = NLA_U32 },
        [IFLA_IPTUN_PROTO]              = { .type = NLA_U8 },
index 8ffea82..be05938 100644 (file)
@@ -345,7 +345,7 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
 +MODULE_LICENSE("GPL v2");
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -232,6 +232,15 @@ config SPI_IMG_SPFI
+@@ -242,6 +242,15 @@ config SPI_IMG_SPFI
          This enables support for the SPFI master controller found on
          IMG SoCs.
  
@@ -363,7 +363,7 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
        depends on ARCH_MXC || COMPILE_TEST
 --- a/drivers/spi/Makefile
 +++ b/drivers/spi/Makefile
-@@ -40,6 +40,7 @@ obj-$(CONFIG_SPI_FSL_LIB)            += spi-fsl-li
+@@ -41,6 +41,7 @@ obj-$(CONFIG_SPI_FSL_LIB)            += spi-fsl-li
  obj-$(CONFIG_SPI_FSL_ESPI)            += spi-fsl-espi.o
  obj-$(CONFIG_SPI_FSL_SPI)             += spi-fsl-spi.o
  obj-$(CONFIG_SPI_GPIO)                        += spi-gpio.o