kernel: add usb3 module definitions
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 19 Jan 2014 17:27:40 +0000 (17:27 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 19 Jan 2014 17:27:40 +0000 (17:27 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39331 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/usb.mk

index 5d26190..825b29e 100644 (file)
@@ -1132,3 +1132,21 @@ define KernelPackage/usbmon/description
 endef
 
 $(eval $(call KernelPackage,usbmon))
+
+
+define KernelPackage/usb3
+  TITLE:=Support for USB3 controllers
+  KCONFIG:= \
+       CONFIG_USB_XHCI_HCD \
+       CONFIG_USB_XHCI_HCD_DEBUGGING=n
+  FILES:= \
+       $(LINUX_DIR)/drivers/usb/host/xhci-hcd.ko
+  AUTOLOAD:=$(call AutoLoad,54,xhci-hcd,1)
+  $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb3/description
+ Kernel support for USB3 (XHCI) controllers
+endef
+
+$(eval $(call KernelPackage,usb3))