[kernel] update to 2.6.25.15 and 2.6.26.2
authorGabor Juhos <juhosg@openwrt.org>
Thu, 7 Aug 2008 16:52:52 +0000 (16:52 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 7 Aug 2008 16:52:52 +0000 (16:52 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12242 3c298f89-4303-0410-b956-a3cf2f4a3e73

21 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar7/Makefile
target/linux/ar71xx/Makefile
target/linux/at91/Makefile
target/linux/atheros/Makefile
target/linux/au1000/Makefile
target/linux/avr32/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/etrax/Makefile
target/linux/generic-2.6/patches-2.6.25/965-cdc_acm_unlock.patch
target/linux/generic-2.6/patches-2.6.26/402-ledtrig_netdev.patch
target/linux/generic-2.6/patches-2.6.26/801-usb_serial_endpoint_size.patch
target/linux/ifxmips/Makefile
target/linux/ixp4xx/Makefile
target/linux/magicbox/Makefile
target/linux/orion/Makefile
target/linux/ps3/Makefile
target/linux/uml/Makefile
target/linux/x86/Makefile

index d06e419..52eef9d 100644 (file)
@@ -25,11 +25,11 @@ endif
 ifeq ($(LINUX_VERSION),2.6.24.7)
   LINUX_KERNEL_MD5SUM:=40a73780d51525d28d36dec852c680c4
 endif
-ifeq ($(LINUX_VERSION),2.6.25.12)
-  LINUX_KERNEL_MD5SUM:=7c413ecf94a84776aaec6ada5694318c
+ifeq ($(LINUX_VERSION),2.6.25.15)
+  LINUX_KERNEL_MD5SUM:=13ed94f02fc2a11615e3332e1cdf50e7
 endif
-ifeq ($(LINUX_VERSION),2.6.26)
-  LINUX_KERNEL_MD5SUM:=5169d01c405bc3f866c59338e217968c
+ifeq ($(LINUX_VERSION),2.6.26.2)
+  LINUX_KERNEL_MD5SUM:=82472622bd26bed0054790ec3e60ee00
 endif
 
 # disable the md5sum check for unknown kernel versions
index e97a80a..f87f9ea 100644 (file)
@@ -9,8 +9,8 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-#LINUX_VERSION:=2.6.25.12
-LINUX_VERSION:=2.6.26
+#LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.26.2
 SUBTARGETS:=router_le router_be
 INITRAMFS_EXTRA_FILES:=
 
index a40dc59..f6da812 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 include $(INCLUDE_DIR)/target.mk
 
index 962f98f..66b1efc 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ar71xx
 BOARDNAME:=Atheros AR71xx
 FEATURES:=squashfs tgz broken
 
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.26.2
 
 include $(INCLUDE_DIR)/target.mk
 
index 00514c7..90d1008 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=at91
 BOARDNAME:=Atmel AT91
 FEATURES:=squashfs usb
 
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 include $(INCLUDE_DIR)/target.mk
 
index fa292ac..1544f82 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros 231x/5312
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.26.2
 
 include $(INCLUDE_DIR)/target.mk
 
index e0228c5..25f94fc 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=au1000
 BOARDNAME:=RMI/AMD AU1x00
 FEATURES:=jffs2 usb pci
 
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += yamonenv
index a9af238..de38c65 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=avr32
 BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 include $(INCLUDE_DIR)/target.mk
 
index 246c59a..3ec9bbb 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb
 
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-switch kmod-diag
index e232b00..79d21f6 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM963xx
 FEATURES:=squashfs jffs2 broken usb atm
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 include $(INCLUDE_DIR)/target.mk
 
index 85911fb..a08d6b8 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=cris
 BOARD:=etrax
 BOARDNAME:=Foxboard (ETRAX 100LX)
 FEATURES:=squashfs jffs2 broken
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 include $(INCLUDE_DIR)/target.mk
 
index 7107a93..c70181c 100644 (file)
@@ -1,5 +1,5 @@
---- linux-2.6.25.12/drivers/usb/class/cdc-acm.c        2008-07-24 18:14:20.000000000 +0200
-+++ linux-2.6.25.12.new/drivers/usb/class/cdc-acm.c    2008-08-05 21:39:35.000000000 +0200
+--- a/drivers/usb/class/cdc-acm.c
++++ b/drivers/usb/class/cdc-acm.c
 @@ -531,8 +531,8 @@
        tasklet_schedule(&acm->urb_task);
  
index 1dcdad6..8a564b2 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.26/drivers/leds/Kconfig
-===================================================================
---- linux-2.6.26.orig/drivers/leds/Kconfig     2008-08-04 15:03:44.000000000 +0200
-+++ linux-2.6.26/drivers/leds/Kconfig  2008-08-04 15:04:18.000000000 +0200
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
 @@ -200,4 +200,11 @@
        tristate "LED Morse Trigger"
        depends on LEDS_TRIGGERS
@@ -14,10 +12,8 @@ Index: linux-2.6.26/drivers/leds/Kconfig
 +        If unsure, say Y.
 +
  endif # NEW_LEDS
-Index: linux-2.6.26/drivers/leds/Makefile
-===================================================================
---- linux-2.6.26.orig/drivers/leds/Makefile    2008-08-04 15:03:40.000000000 +0200
-+++ linux-2.6.26/drivers/leds/Makefile 2008-08-04 15:04:29.000000000 +0200
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
 @@ -29,3 +29,4 @@
  obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT)  += ledtrig-heartbeat.o
  obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
index e856dc1..f1bd446 100644 (file)
@@ -8,7 +8,7 @@
  static int debug;
  static struct usb_serial *serial_table[SERIAL_TTY_MINORS];    /* initially all NULL */
  static DEFINE_MUTEX(table_lock);
-@@ -812,7 +813,7 @@
+@@ -815,7 +816,7 @@
                        dev_err(&interface->dev, "No free urbs available\n");
                        goto probe_error;
                }
@@ -17,7 +17,7 @@
                port->bulk_in_size = buffer_size;
                port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
                port->bulk_in_buffer = kmalloc (buffer_size, GFP_KERNEL);
-@@ -1226,3 +1227,5 @@
+@@ -1229,3 +1230,5 @@
  
  module_param(debug, bool, S_IRUGO | S_IWUSR);
  MODULE_PARM_DESC(debug, "Debug enabled or not");
index 04c620c..060782b 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
 FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES:=uboot-ifxmips
index cdfc4cb..897a2fa 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Intel IXP4xx
 FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.26.2
 
 include $(INCLUDE_DIR)/target.mk
 
index a804184..fcdd285 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=magicbox
 BOARDNAME:=Magicbox
 FEATURES:=squashfs pci
 
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.26.2
 LINUX_KARCH:=ppc
 
 include $(INCLUDE_DIR)/target.mk
index d5b8ba3..c947437 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=orion
 BOARDNAME:=Marvell Orion
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.26.2
 
 include $(INCLUDE_DIR)/target.mk
 
index 0fe4883..a9e69a8 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=powerpc
 BOARD:=ps3
 BOARDNAME:=Sony PS3 Game Console
 
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 KERNEL_CC:=
 
index f4298f5..3dd9a98 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext2
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.26.2
 
 include $(INCLUDE_DIR)/target.mk
 
index 4d11d7f..2d29198 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext2 vdi
 SUBTARGETS=generic
 
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci