store stamp file for 'development headers installed' in the staging dir instead of...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Jun 2006 16:12:05 +0000 (16:12 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Jun 2006 16:12:05 +0000 (16:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3895 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/rules.mk

index 79c2b34..1fd6f2a 100644 (file)
@@ -29,17 +29,18 @@ define Build/DefaultTargets
        $(call Build/Compile)
        touch $$@
 
-  $(PKG_BUILD_DIR)/.dev-installed: $(PKG_BUILD_DIR)/.built
+  $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed: $(PKG_BUILD_DIR)/.built
        $(call Build/InstallDev)
        touch $$@
        
   ifdef Build/InstallDev
-    compile-targets: $(PKG_BUILD_DIR)/.dev-installed
+    compile-targets: $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
   endif
 
   package-clean: FORCE
        $(call Build/Clean)
        $(call Build/UninstallDev)
+       rm -f $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
 
   package-rebuild: FORCE
        @-rm $(PKG_BUILD_DIR)/.built