ar71xx: select u-boot for the NBG460N in the Default/Minimal profiles as well
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 Dec 2010 15:17:08 +0000 (15:17 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 Dec 2010 15:17:08 +0000 (15:17 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24421 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/uboot-ar71xx/Makefile
target/linux/ar71xx/generic/profiles/00-default.mk
target/linux/ar71xx/generic/profiles/01-minimal.mk

index 83d66d4..86a20a8 100644 (file)
@@ -36,7 +36,7 @@ define Package/uboot/template
 define Package/uboot-ar71xx-$(1)
   SECTION:=boot
   CATEGORY:=Boot Loaders
-  DEPENDS:=@TARGET_ar71xx_generic_NBG_460N_550N_550NH
+  DEPENDS:=@TARGET_ar71xx_generic_Default||TARGET_ar71xx_generic_Minimal||TARGET_ar71xx_generic_NBG_460N_550N_550NH
   TITLE:=$(2)
   URL:=http://www.denx.de/wiki/U-Boot
   VARIANT:=$(1)
index 2ca9fa6..69a7a9f 100644 (file)
@@ -7,7 +7,10 @@
 
 define Profile/Default
        NAME:=Default Profile (all drivers)
-       PACKAGES:=kmod-ath9k kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig vsc7385-ucode-ap83 vsc7385-ucode-pb44 vsc7395-ucode-ap83 vsc7395-ucode-pb44 wpad-mini
+       PACKAGES:= \
+               kmod-ath9k kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig \
+               vsc7385-ucode-ap83 vsc7385-ucode-pb44 vsc7395-ucode-ap83 \
+               vsc7395-ucode-pb44 wpad-mini uboot-ar71xx-nbg460n_550n_550nh
 endef
 
 define Profile/Default/Description
index 812ae6f..d92eb15 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Minimal
        NAME:=Minimal Profile (no drivers)
-       PACKAGES:=
+       PACKAGES:=uboot-ar71xx-nbg460n_550n_550nh
 endef
 
 define Profile/Minimal/Description