[kernel]: package the gpio-fan module
authorImre Kaloz <kaloz@openwrt.org>
Fri, 20 Jun 2014 20:42:47 +0000 (20:42 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Fri, 20 Jun 2014 20:42:47 +0000 (20:42 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41289 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/hwmon.mk

index 7831f70..459e520 100644 (file)
@@ -259,6 +259,7 @@ endef
 
 $(eval $(call KernelPackage,hwmon-gsc))
 
+
 define KernelPackage/hwmon-tmp421
   TITLE:=TI TMP421 and compatible monitoring support
   KCONFIG:=CONFIG_SENSORS_TMP421
@@ -272,3 +273,18 @@ define KernelPacakge/hwmon-tmp421/description
 endef
 
 $(eval $(call KernelPackage,hwmon-tmp421))
+
+
+define KernelPackage/hwmon-gpiofan
+  TITLE:=Generic GPIO FAN support
+  KCONFIG:=CONFIG_SENSORS_GPIO_FAN
+  FILES:=$(LINUX_DIR)/drivers/hwmon/gpio-fan.ko
+  AUTOLOAD:=$(call AutoLoad,60,gpio-fan)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPacakge/hwmon-gpiofan/description
+  Kernel module for GPIO controlled FANs
+endef
+
+$(eval $(call KernelPackage,hwmon-gpiofan))