projects
/
15.05
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
cd9eb98
)
tools/upx: use HOSTCXX to fix build errors on mac os x
author
Felix Fietkau
<nbd@openwrt.org>
Fri, 22 Mar 2013 12:52:21 +0000
(12:52 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Fri, 22 Mar 2013 12:52:21 +0000
(12:52 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36110
3c298f89
-4303-0410-b956-
a3cf2f4a3e73
tools/upx/Makefile
patch
|
blob
|
history
diff --git
a/tools/upx/Makefile
b/tools/upx/Makefile
index
3e76232
..
c162e55
100644
(file)
--- a/
tools/upx/Makefile
+++ b/
tools/upx/Makefile
@@
-21,7
+21,8
@@
include $(INCLUDE_DIR)/host-build.mk
define Host/Compile
rm -f $(HOST_BUILD_DIR)/src/.depend
$(MAKE) UPX_LZMADIR="$(BUILD_DIR_HOST)/lzma-4.65" -C $(HOST_BUILD_DIR)/src \
- CXXFLAGS_WERROR="" LDFLAGS="$(HOST_LDFLAGS) $(HOST_STATIC_LINKING)"
+ CXXFLAGS_WERROR="" LDFLAGS="$(HOST_LDFLAGS) $(HOST_STATIC_LINKING)" \
+ CXX="$(HOSTCXX)"
endef
define Host/Install